summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-12-03 10:18:08 +1300
committercaltlgin2020-12-03 10:18:08 +1300
commit7669e08ca8bf7a61c8fae8542b38a4b7dd4dc2e8 (patch)
treed7333fcbf1b3f5a9fb58754ba4d924a512756455
parent95492bdcdbb8ec3d8246a9208032263c20538540 (diff)
downloadaur-7669e08ca8bf7a61c8fae8542b38a4b7dd4dc2e8.tar.gz
Python 3.9 rebuild
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD9
3 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87ebc6125553..333b2efad424 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cleanpy
pkgdesc = CLI tool to remove caches and temporary files related to Python
pkgver = 0.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/thombashi/cleanpy
arch = any
license = MIT
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index b753eee19ea1..c69a2ecd0348 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
-pkgname=cleanpy
+pkgname='cleanpy'
pkgver=0.1.0
-pkgrel=1
+pkgrel=2
pkgdesc='CLI tool to remove caches and temporary files related to Python'
arch=('any')
url='https://github.com/thombashi/cleanpy'
+_url_pypi='https://pypi.org/project/cleanpy'
license=('MIT')
depends=('python')
makedepends=('python-setuptools')
@@ -20,8 +21,8 @@ build() {
package() {
cd "${pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.rst'
- install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE'
+ install -Dvm644 'README.rst' -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim: ts=2 sw=2 et: