summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-08-08 11:51:03 +1200
committercaltlgin2020-08-08 11:51:03 +1200
commit95492bdcdbb8ec3d8246a9208032263c20538540 (patch)
tree6da33abd191617e8d0c6192f85edcc669691bdb5
downloadaur-95492bdcdbb8ec3d8246a9208032263c20538540.tar.gz
Add to AUR
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87ebc6125553
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = cleanpy
+ pkgdesc = CLI tool to remove caches and temporary files related to Python
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/thombashi/cleanpy
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/c/cleanpy/cleanpy-0.1.0.tar.gz
+ sha256sums = d0a6291bffb2b92f10d3c605a51fba995b4155875206626df060eac30cdb7ff9
+
+pkgname = cleanpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b753eee19ea1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+pkgname=cleanpy
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='CLI tool to remove caches and temporary files related to Python'
+arch=('any')
+url='https://github.com/thombashi/cleanpy'
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('d0a6291bffb2b92f10d3c605a51fba995b4155875206626df060eac30cdb7ff9')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.rst'
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE'
+}
+
+# vim: ts=2 sw=2 et: