summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2024-03-02 19:47:28 +0100
committerFabioLolix2024-03-02 19:47:28 +0100
commite7682090a502158a74fb6b7a36deb481f29a6baf (patch)
treee9776df763072e2c89a8662bc4f87aed8b9a207d
parent98d4ae5cdc4369d117812ff14335c361635cf81a (diff)
downloadaur-e7682090a502158a74fb6b7a36deb481f29a6baf.tar.gz
use bundled taglib1 since it don't dirty build if taglib(2) is present
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 4 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cb1b6fe83b6..5cb0cd35f808 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = clementine
pkgdesc = A modern music player and library organizer
pkgver = 1.4.0rc2
- pkgrel = 5
+ pkgrel = 6
url = https://www.clementine-player.org/
arch = x86_64
license = GPL
@@ -16,7 +16,6 @@ pkgbase = clementine
depends = liblastfm-qt5
depends = libmtp
depends = libmygpo-qt5
- depends = taglib1
depends = protobuf
depends = qt5-x11extras
depends = projectm
diff --git a/PKGBUILD b/PKGBUILD
index f04a848c4e5a..b9009152630d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,13 @@
pkgname=clementine
pkgver=1.4.0rc2
-pkgrel=5
+pkgrel=6
pkgdesc='A modern music player and library organizer'
url=https://www.clementine-player.org/
license=(GPL)
arch=(x86_64)
depends=(chromaprint gst-plugins-base-libs libcdio libgpod liblastfm-qt5 libmtp libmygpo-qt5
- taglib1 protobuf qt5-x11extras projectm alsa-lib libpulse crypto++ hicolor-icon-theme)
+ protobuf qt5-x11extras projectm alsa-lib libpulse crypto++ hicolor-icon-theme)
makedepends=(boost cmake qt5-tools sparsehash)
optdepends=(
'gst-plugins-base: "Base" plugin libraries'
@@ -30,13 +30,12 @@ prepare() {
build() {
export LDFLAGS="-Wl,--copy-dt-needed-entries"
- export PKG_CONFIG_PATH=/usr/lib/taglib1/lib/pkgconfig
cmake -B build -S Clementine-${pkgver//+/-} -Wno-dev \
-DCMAKE_CXX_FLAGS="-fpermissive" \
-DCMAKE_CXX_STANDARD=17 \
-DCMAKE_INSTALL_PREFIX=/usr \
-DUSE_SYSTEM_PROJECTM=ON \
- -DUSE_SYSTEM_TAGLIB=ON
+ -DUSE_SYSTEM_TAGLIB=OFF
cmake --build build
}