summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvlad2015-07-08 15:39:09 +0300
committervlad2015-07-08 15:39:09 +0300
commit9da71d88afcfd4bd9235dfaf939810cdf87785a4 (patch)
treea23e6472009d5d6cb0281ed92c8979c43d774e64
downloadaur-9da71d88afcfd4bd9235dfaf939810cdf87785a4.tar.gz
Initial import
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD85
-rw-r--r--clementine.install13
3 files changed, 139 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb8e1a229bf2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = clementine-git
+ pkgdesc = A modern music player and library organiser and a port of Amarok 1.4, with some features rewritten to take advantage of Qt4.
+ pkgver = 1.2.3.1109.g7cd4a56
+ pkgrel = 1
+ url = http://www.clementine-player.org/
+ install = clementine.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = boost
+ makedepends = cmake
+ makedepends = mesa
+ depends = gst-plugins-base
+ depends = taglib
+ depends = glew
+ depends = liblastfm
+ depends = libgpod
+ depends = libmtp
+ depends = libplist
+ depends = hicolor-icon-theme
+ depends = qt4
+ depends = sparsehash
+ depends = libechonest
+ depends = qjson
+ depends = libcdio
+ depends = protobuf
+ depends = crypto++
+ depends = chromaprint
+ depends = libmygpo-qt
+ optdepends = gst-plugins-good: for use with "Good" plugin libraries
+ optdepends = gst-plugins-bad: for use with "Bad" plugin libraries
+ optdepends = gst-plugins-ugly: for use with "Ugly" plugin libraries
+ provides = clementine
+ conflicts = clementine
+ replaces = clementine
+ source = git+https://github.com/clementine-player/Clementine.git
+ sha256sums = SKIP
+
+pkgname = clementine-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..762e27bf7bf8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,85 @@
+# Mantainer: Adria Arrufat <swiftscythe@gmail.com>
+# Contributor: Ike Devolder <ike.devolder@gmail.com>
+# Contributor: Daniel Hill <daniel.hill@orcon.net.nz>
+# Contributor: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+
+pkgname=clementine-git
+pkgver=1.2.3.1109.g7cd4a56
+pkgrel=1
+pkgdesc="A modern music player and library organiser and a port of Amarok 1.4, with some features rewritten to take advantage of Qt4."
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('gst-plugins-base' 'taglib' 'glew' 'liblastfm' 'libgpod'
+ 'libmtp' 'libplist' 'hicolor-icon-theme' 'qt4' 'sparsehash' 'libechonest'
+ 'qjson' 'libcdio' 'protobuf' 'crypto++' 'chromaprint' 'libmygpo-qt')
+optdepends=('gst-plugins-good: for use with "Good" plugin libraries'
+ 'gst-plugins-bad: for use with "Bad" plugin libraries'
+ 'gst-plugins-ugly: for use with "Ugly" plugin libraries'
+)
+makedepends=('git' 'boost' 'cmake' 'mesa')
+install=clementine.install
+# Uncomment next lines to enable more features
+#makedepends+=('libspotify' 'libgpod' 'libimobiledevice')
+#optdepends+=(
+#'libspotify: for Spotify support'
+#'libgpod: for iPod support'
+#'libimobiledevice: for iPhone and iPod Touch support'
+#)
+
+url="http://www.clementine-player.org/"
+source=('git+https://github.com/clementine-player/Clementine.git')
+sha256sums=('SKIP')
+
+provides=('clementine')
+conflicts=('clementine')
+replaces=('clementine')
+
+
+pkgver() {
+ cd Clementine
+ git describe | sed 's/^v//;s/-/./g;s/_/./g;'
+}
+
+prepare() {
+ echo "Patching sources"
+ sed -i 's/crypto++/cryptopp/g' ${srcdir}/Clementine/src/internet/spotify/spotifyblobdownloader.cpp
+}
+
+build() {
+ # rm -rf build
+ mkdir -p build
+ cd build
+
+ cmake "../Clementine" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DENABLE_VISUALISATIONS=OFF \
+ -DENABLE_SPOTIFY_BLOB=OFF \
+ -DENABLE_SKYDRIVE=OFF \
+ -DENABLE_GOOGLE_DRIVE=OFF \
+ -DENABLE_DROPBOX=OFF \
+ -DENABLE_UBUNTU_ONE=OFF \
+ -DENABLE_LIBGPOD=OFF \
+ -DENABLE_WIIMOTEDEV=OFF \
+ -DENABLE_SPARKLE=OFF \
+ -DENABLE_LIBMTP=OFF \
+ -DENABLE_GIO=ON \
+ -DENABLE_BOX=OFF \
+ -DLINGUAS="en"
+# -DENABLE_xxxx
+# - force their inclusion with =ON - this could trigger an error for
+# unlisted dependencies in depends=()
+# - remove them to get auto-detected - this could include (without notice)
+# packages not listed in depends=()
+
+# -DCMAKE_BUILD_TYPE remove to get a debug build with symbols
+# -DLINGUAS remove for all translations or put in a space-separated list
+# of translations to be included, eg. ="en es"
+# Qt doesn't respect LC_xxx settings... which is really annoying!
+make
+}
+
+package(){
+ cd build
+ make DESTDIR=${pkgdir} install
+}
diff --git a/clementine.install b/clementine.install
new file mode 100644
index 000000000000..2f0338d8aa65
--- /dev/null
+++ b/clementine.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+
+post_remove() {
+ post_install $1
+}