summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobozzz2015-06-11 19:07:02 +0200
committerChocobozzz2015-06-11 19:07:02 +0200
commit0648632fa3075a01a82cd690dfe2f7f4cb8365ba (patch)
treeb0b814594b92bf3956f1216bf9e1794e9d4f32cd
downloadaur-0648632fa3075a01a82cd690dfe2f7f4cb8365ba.tar.gz
Initial import
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD56
-rw-r--r--clementine.install13
3 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d7ae6c63558
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = clementine-qt5-git
+ pkgdesc = Experimental Qt5 version of Clementine, a modern music player and library organiser.
+ pkgver = 1.2.3.r1195.gcc079ec
+ pkgrel = 1
+ url = http://www.clementine-player.org/
+ install = clementine.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = boost
+ makedepends = cmake
+ makedepends = mesa
+ depends = gst-plugins-base
+ depends = gst-libav
+ depends = taglib
+ depends = glew
+ depends = liblastfm-qt5-git
+ depends = libgpod
+ depends = desktop-file-utils
+ depends = libmtp
+ depends = libplist
+ depends = hicolor-icon-theme
+ depends = qt5-base
+ depends = sparsehash
+ depends = libechonest-qt5-git
+ depends = libcdio
+ depends = protobuf
+ depends = crypto++
+ depends = chromaprint
+ depends = libmygpo-qt5-git
+ optdepends = gst-plugins-good: for use with "Good" plugin libraries
+ optdepends = gst-plugins-bad: for use with "Bad" plugin libraries
+ optdepends = gst-plugins-ugly: for use with "Ugly" plugin libraries
+ provides = clementine
+ conflicts = clementine
+ replaces = clementine
+ source = git+https://github.com/clementine-player/Clementine.git#branch=qt5
+ sha256sums = SKIP
+
+pkgname = clementine-qt5-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..542ab0b500ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Florian Bigard <florian.bigard@gmail.com>
+# Thanks to Adria Arrufat <swiftscythe@gmail.com>
+
+pkgname=clementine-qt5-git
+pkgver=1.2.3.r1195.gcc079ec
+pkgrel=1
+pkgdesc="Experimental Qt5 version of Clementine, a modern music player and library organiser."
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('gst-plugins-base' 'gst-libav' 'taglib' 'glew' 'liblastfm-qt5-git'
+ 'libgpod' 'desktop-file-utils' 'libmtp' 'libplist' 'hicolor-icon-theme'
+ 'qt5-base' 'sparsehash' 'libechonest-qt5-git' 'libcdio' 'protobuf'
+ 'crypto++' 'chromaprint' 'libmygpo-qt5-git')
+optdepends=('gst-plugins-good: for use with "Good" plugin libraries'
+ 'gst-plugins-bad: for use with "Bad" plugin libraries'
+ 'gst-plugins-ugly: for use with "Ugly" plugin libraries'
+)
+makedepends=('git' 'boost' 'cmake' 'mesa')
+install=clementine.install
+# Uncomment next lines to enable more features
+#makedepends+=('libspotify' 'libgpod' 'libimobiledevice')
+#optdepends+=(
+#'libspotify: for Spotify support'
+#'libgpod: for iPod support'
+#'libimobiledevice: for iPhone and iPod Touch support'
+#)
+
+url="http://www.clementine-player.org/"
+source=('git+https://github.com/clementine-player/Clementine.git#branch=qt5')
+sha256sums=('SKIP')
+
+provides=('clementine')
+conflicts=('clementine')
+replaces=('clementine')
+
+
+pkgver() {
+ cd Clementine
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ mkdir -p build
+ cd build
+
+ # Don't make a release build since it's experimental and we would need debug/info/warning messages
+ # Add -DCMAKE_BUILD_TYPE=Release if you're an adventurer
+ cmake "../Clementine" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package(){
+ cd build
+ make DESTDIR=${pkgdir} install
+}
diff --git a/clementine.install b/clementine.install
new file mode 100644
index 000000000000..2f0338d8aa65
--- /dev/null
+++ b/clementine.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+
+post_remove() {
+ post_install $1
+}