summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobozzz2018-12-07 16:06:54 +0100
committerChocobozzz2018-12-07 16:06:54 +0100
commit1bac7ec77a9ec18cc042bdb51e036757c3711905 (patch)
tree38828bdcea085dad8d17b3d7f8d50e817fd0e75f
parent97334e6c6b84c8cc43bafabca5a5c4ed2c585602 (diff)
downloadaur-1bac7ec77a9ec18cc042bdb51e036757c3711905.tar.gz
Fix clementine with latest qt5 branch
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--qtdbus.patch194
-rw-r--r--spotify_blob.patch78
-rw-r--r--spotify_install.patch21
5 files changed, 202 insertions, 111 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c6262aae51b..2b138258fbbb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Jun 4 07:47:51 UTC 2018
+# Fri Dec 7 15:06:49 UTC 2018
pkgbase = clementine-qt5-git
pkgdesc = Experimental Qt5 version of Clementine, a modern music player and library organiser.
- pkgver = 1.3.1.r545.g4619a4c1a
+ pkgver = 1.3.1.r659.g453270c8b
pkgrel = 1
url = http://www.clementine-player.org/
install = clementine.install
@@ -44,11 +44,9 @@ pkgbase = clementine-qt5-git
replaces = clementine-lxqt
replaces = clementine-git
source = git+https://github.com/clementine-player/Clementine.git#branch=qt5
- source = spotify_install.patch
- source = spotify_blob.patch
+ source = qtdbus.patch
sha256sums = SKIP
- sha256sums = 05a438fb445790200258c536d396a6bda9df38a9b775d5259421376ec1878786
- sha256sums = 440b7e0b9b70d3e379ec9404eb09c8eca584188d81269904fd57375671a74a8e
+ sha256sums = 289ba9393bec5def2ed4fef317be3bdfa749081b85c5e743de4dd223bb666b5c
pkgname = clementine-qt5-git
diff --git a/PKGBUILD b/PKGBUILD
index b503862254a6..922e8077f615 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Thanks to Adria Arrufat <swiftscythe@gmail.com>
pkgname=clementine-qt5-git
-pkgver=1.3.1.r545.g4619a4c1a
+pkgver=1.3.1.r659.g453270c8b
pkgrel=1
pkgdesc="Experimental Qt5 version of Clementine, a modern music player and library organiser."
arch=('i686' 'x86_64')
@@ -27,9 +27,8 @@ optdepends=(
url="http://www.clementine-player.org/"
source=('git+https://github.com/clementine-player/Clementine.git#branch=qt5'
- 'spotify_install.patch' 'spotify_blob.patch')
-sha256sums=('SKIP' '05a438fb445790200258c536d396a6bda9df38a9b775d5259421376ec1878786'
- '440b7e0b9b70d3e379ec9404eb09c8eca584188d81269904fd57375671a74a8e')
+ 'qtdbus.patch')
+sha256sums=('SKIP' '289ba9393bec5def2ed4fef317be3bdfa749081b85c5e743de4dd223bb666b5c')
provides=('clementine')
conflicts=('clementine' 'clementine-lxqt' 'clementine-git')
@@ -43,8 +42,7 @@ pkgver() {
prepare() {
cd Clementine
- patch -Np1 -i ../spotify_blob.patch
- patch -Np0 -i ../spotify_install.patch
+ patch -Np1 -i ../qtdbus.patch
}
build() {
diff --git a/qtdbus.patch b/qtdbus.patch
new file mode 100644
index 000000000000..fe9c1661d922
--- /dev/null
+++ b/qtdbus.patch
@@ -0,0 +1,194 @@
+From f8c22291ed70a6e0713ace978ce0272105b9e7dd Mon Sep 17 00:00:00 2001
+From: Chocobozzz <me@florianbigard.com>
+Date: Fri, 7 Dec 2018 15:54:56 +0100
+Subject: [PATCH] Revert "Fixes for compiling against qt5 on mac"
+
+This reverts commit 453270c8b5015f39a44fd34c659e811c6b8048cf.
+---
+ 3rdparty/libmygpo-qt5/src/CMakeLists.txt | 3 ++-
+ 3rdparty/qocoa/CMakeLists.txt | 2 +-
+ CMakeLists.txt | 6 ++++++
+ dist/macdeploy.py | 23 +++++++----------------
+ ext/clementine-tagreader/CMakeLists.txt | 4 ++--
+ ext/libclementine-common/CMakeLists.txt | 5 +++--
+ src/CMakeLists.txt | 15 +++------------
+ 7 files changed, 24 insertions(+), 34 deletions(-)
+
+diff --git a/3rdparty/libmygpo-qt5/src/CMakeLists.txt b/3rdparty/libmygpo-qt5/src/CMakeLists.txt
+index 5098160aa..c15771c3e 100644
+--- a/3rdparty/libmygpo-qt5/src/CMakeLists.txt
++++ b/3rdparty/libmygpo-qt5/src/CMakeLists.txt
+@@ -84,4 +84,5 @@ QT_WRAP_CPP(LIBMYGPO_QT_MOC_SRC ${LIBMYGPO_QT_MOC_H} )
+
+ add_library( ${MYGPO_QT_TARGET_NAME} STATIC ${LIBMYGPO_QT_SRC} ${LIBMYGPO_QT_MOC_SRC} )
+
+-target_link_libraries( ${MYGPO_QT_TARGET_NAME} ${QJSON_LIBRARIES} Qt5::Core Qt5::Network )
++target_link_libraries( ${MYGPO_QT_TARGET_NAME} ${QJSON_LIBRARIES} ${QT_QTCORE_LIBRARY} ${QT_QTNETWORK_LIBRARY} )
++target_link_libraries( ${MYGPO_QT_TARGET_NAME} Qt5::Core Qt5::Network )
+diff --git a/3rdparty/qocoa/CMakeLists.txt b/3rdparty/qocoa/CMakeLists.txt
+index a52ee2e24..b3b7fa4aa 100644
+--- a/3rdparty/qocoa/CMakeLists.txt
++++ b/3rdparty/qocoa/CMakeLists.txt
+@@ -29,4 +29,4 @@ endif()
+ add_library(Qocoa STATIC
+ ${SOURCES} ${MOC_SOURCES} ${RESOURCES_SOURCES}
+ )
+-target_link_libraries(Qocoa Qt5::Widgets Qt5::MacExtras)
++target_link_libraries(Qocoa ${QT_LIBRARIES})
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c8130577e..dbc2c96e0 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -35,6 +35,12 @@ if (${CMAKE_SYSTEM_NAME} STREQUAL "FreeBSD")
+ set(FREEBSD ON)
+ endif()
+
++if(APPLE)
++ if(NOT QT_MAC_USE_COCOA)
++ message(FATAL_ERROR "Cocoa support is required")
++ endif(NOT QT_MAC_USE_COCOA)
++endif(APPLE)
++
+ set(OpenGL_GL_PREFERENCE LEGACY)
+ find_package(OpenGL)
+ if(OPENGL_FOUND)
+diff --git a/dist/macdeploy.py b/dist/macdeploy.py
+index 08fa5ca7e..3371eaed7 100755
+--- a/dist/macdeploy.py
++++ b/dist/macdeploy.py
+@@ -30,11 +30,6 @@ FRAMEWORK_SEARCH_PATH = [
+ os.path.join(os.environ['HOME'], 'Library/Frameworks')
+ ]
+
+-STRIP_PREFIX = [
+- '@@HOMEBREW_PREFIX@@/opt/qt5/lib/',
+- '@@HOMEBREW_CELLAR@@/qt5/5.8.0_1/lib/',
+-]
+-
+ LIBRARY_SEARCH_PATH = ['/target', '/target/lib', '/usr/local/lib', '/sw/lib']
+
+ GSTREAMER_PLUGINS = [
+@@ -59,7 +54,7 @@ GSTREAMER_PLUGINS = [
+ 'libgstapetag.so',
+ 'libgstasf.so',
+ 'libgstaudioparsers.so',
+- #'libgstfaac.so',
++ 'libgstfaac.so',
+ 'libgstfaad.so',
+ 'libgstflac.so',
+ 'libgstid3demux.so',
+@@ -99,16 +94,16 @@ GSTREAMER_SEARCH_PATH = [
+ ]
+
+ QT_PLUGINS = [
+- #'accessible/libqtaccessiblewidgets.dylib',
+- #'codecs/libqcncodecs.dylib',
+- #'codecs/libqjpcodecs.dylib',
+- #'codecs/libqkrcodecs.dylib',
+- #'codecs/libqtwcodecs.dylib',
++ 'accessible/libqtaccessiblewidgets.dylib',
++ 'codecs/libqcncodecs.dylib',
++ 'codecs/libqjpcodecs.dylib',
++ 'codecs/libqkrcodecs.dylib',
++ 'codecs/libqtwcodecs.dylib',
+ 'iconengines/libqsvgicon.dylib',
+ 'imageformats/libqgif.dylib',
+ 'imageformats/libqico.dylib',
+ 'imageformats/libqjpeg.dylib',
+- #'imageformats/libqmng.dylib',
++ 'imageformats/libqmng.dylib',
+ 'imageformats/libqsvg.dylib',
+ ]
+ QT_PLUGINS_SEARCH_PATH = [
+@@ -211,10 +206,6 @@ def GetBrokenLibraries(binary):
+
+
+ def FindFramework(path):
+- for prefix in STRIP_PREFIX:
+- if path.startswith(prefix):
+- path = path[len(prefix):]
+- break
+ for search_path in FRAMEWORK_SEARCH_PATH:
+ abs_path = os.path.join(search_path, path)
+ if os.path.exists(abs_path):
+diff --git a/ext/clementine-tagreader/CMakeLists.txt b/ext/clementine-tagreader/CMakeLists.txt
+index 855e390cf..d846efecd 100644
+--- a/ext/clementine-tagreader/CMakeLists.txt
++++ b/ext/clementine-tagreader/CMakeLists.txt
+@@ -29,8 +29,8 @@ target_link_libraries(clementine-tagreader
+ ${TAGLIB_LIBRARIES}
+ libclementine-common
+ libclementine-tagreader
+- Qt5::Core
+- Qt5::Network
++ ${QT_QTCORE_LIBRARY}
++ ${QT_QTNETWORK_LIBRARY}
+ z
+ )
+
+diff --git a/ext/libclementine-common/CMakeLists.txt b/ext/libclementine-common/CMakeLists.txt
+index 694836c9e..200f73c96 100644
+--- a/ext/libclementine-common/CMakeLists.txt
++++ b/ext/libclementine-common/CMakeLists.txt
+@@ -35,8 +35,9 @@ add_library(libclementine-common STATIC
+ )
+
+ target_link_libraries(libclementine-common
+- Qt5::Core
+- Qt5::Network
++ ${QT_LIBRARIES}
+ ${TAGLIB_LIBRARIES}
+ ${CMAKE_THREAD_LIBS_INIT}
+ )
++
++target_link_libraries(libclementine-common Qt5::Core Qt5::Network)
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 88dff3c20..76654a4c3 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -1244,22 +1244,13 @@ target_link_libraries(clementine_lib
+ libclementine-common
+ libclementine-tagreader
+ libclementine-remote
+-
+- Qt5::Concurrent
+- Qt5::Core
+- Qt5::Network
+- Qt5::OpenGL
+- Qt5::OpenGL
+- Qt5::Sql
+- Qt5::Widgets
+- Qt5::Xml
+-
+ ${TAGLIB_LIBRARIES}
+ ${MYGPOQT5_LIBRARIES}
+ ${CHROMAPRINT_LIBRARIES}
+ ${GOBJECT_LIBRARIES}
+ ${GLIB_LIBRARIES}
+ ${GIO_LIBRARIES}
++ ${QT_LIBRARIES}
+ ${GSTREAMER_BASE_LIBRARIES}
+ ${GSTREAMER_LIBRARIES}
+ ${GSTREAMER_APP_LIBRARIES}
+@@ -1270,9 +1261,8 @@ target_link_libraries(clementine_lib
+ ${QTIOCOMPRESSOR_LIBRARIES}
+ ${CMAKE_THREAD_LIBS_INIT}
+ ${SQLITE_LIBRARIES}
+-
+- Qocoa
+ z
++ Qocoa
+ )
+
+ if(HAVE_VISUALISATIONS)
+@@ -1362,6 +1352,7 @@ if (WIN32)
+ ${QTSPARKLE_LIBRARIES}
+ tinysvcmdns
+ dsound
++ ${QT_QTGUI_LIBRARY}
+ )
+ endif (WIN32)
+
+--
+2.19.2
+
diff --git a/spotify_blob.patch b/spotify_blob.patch
deleted file mode 100644
index 11924c79daa7..000000000000
--- a/spotify_blob.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-From e8c87242457ebd597c4f706b3b118afb39dbb742 Mon Sep 17 00:00:00 2001
-From: Chocobozzz <me@florianbigard.com>
-Date: Tue, 6 Feb 2018 08:45:48 +0100
-Subject: [PATCH] Revert "Link statically to libprotobuf from the spotifyblob"
-
-This reverts commit 170c64cd8bef9df2ea88dd4f72eec641c250bcfd.
----
- CMakeLists.txt | 2 --
- ext/clementine-spotifyblob/CMakeLists.txt | 1 -
- ext/libclementine-common/CMakeLists.txt | 1 +
- ext/libclementine-remote/CMakeLists.txt | 1 -
- ext/libclementine-tagreader/CMakeLists.txt | 1 -
- 5 files changed, 1 insertion(+), 5 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 820b13851..3ec57df2b 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -56,8 +56,6 @@ find_package(PkgConfig REQUIRED)
- find_package(Protobuf REQUIRED)
- find_package(FFTW3)
-
--find_library(PROTOBUF_STATIC_LIBRARY libprotobuf.a libprotobuf)
--
- pkg_check_modules(CDIO libcdio)
- pkg_check_modules(CHROMAPRINT REQUIRED libchromaprint)
- pkg_search_module(CRYPTOPP cryptopp libcrypto++)
-diff --git a/ext/clementine-spotifyblob/CMakeLists.txt b/ext/clementine-spotifyblob/CMakeLists.txt
-index ca332dca1..30553bfc4 100644
---- a/ext/clementine-spotifyblob/CMakeLists.txt
-+++ b/ext/clementine-spotifyblob/CMakeLists.txt
-@@ -46,7 +46,6 @@ target_link_libraries(clementine-spotifyblob
- ${QT_QTNETWORK_LIBRARY}
- ${GSTREAMER_BASE_LIBRARIES}
- ${GSTREAMER_APP_LIBRARIES}
-- ${PROTOBUF_STATIC_LIBRARY}
- clementine-spotifyblob-messages
- libclementine-common
- )
-diff --git a/ext/libclementine-common/CMakeLists.txt b/ext/libclementine-common/CMakeLists.txt
-index 2cf31339b..56f46722c 100644
---- a/ext/libclementine-common/CMakeLists.txt
-+++ b/ext/libclementine-common/CMakeLists.txt
-@@ -36,6 +36,7 @@ add_library(libclementine-common STATIC
-
- target_link_libraries(libclementine-common
- ${QT_LIBRARIES}
-+ ${PROTOBUF_LIBRARY}
- ${TAGLIB_LIBRARIES}
- ${CMAKE_THREAD_LIBS_INIT}
- )
-diff --git a/ext/libclementine-remote/CMakeLists.txt b/ext/libclementine-remote/CMakeLists.txt
-index 5f860fbcd..f6fc7685a 100644
---- a/ext/libclementine-remote/CMakeLists.txt
-+++ b/ext/libclementine-remote/CMakeLists.txt
-@@ -11,7 +11,6 @@ add_library(libclementine-remote STATIC
- )
-
- target_link_libraries(libclementine-remote
-- ${PROTOBUF_LIBRARY}
- libclementine-common
- )
-
-diff --git a/ext/libclementine-tagreader/CMakeLists.txt b/ext/libclementine-tagreader/CMakeLists.txt
-index dd75473c9..ba9e3ff31 100644
---- a/ext/libclementine-tagreader/CMakeLists.txt
-+++ b/ext/libclementine-tagreader/CMakeLists.txt
-@@ -38,7 +38,6 @@ add_library(libclementine-tagreader STATIC
- )
-
- target_link_libraries(libclementine-tagreader
-- ${PROTOBUF_LIBRARY}
- libclementine-common
- )
-
---
-2.16.1
-
diff --git a/spotify_install.patch b/spotify_install.patch
deleted file mode 100644
index 3418beef1283..000000000000
--- a/spotify_install.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- ext/clementine-spotifyblob/CMakeLists.txt 2016-03-03 21:42:28.483811815 +0100
-+++ ext/clementine-spotifyblob/CMakeLists.txt.new 2016-03-03 21:42:56.237145560 +0100
-@@ -62,18 +62,3 @@
- RUNTIME DESTINATION bin
- )
- endif(NOT APPLE)
--
--if(LINUX)
-- # Versioned name of the blob
-- if(CMAKE_SIZEOF_VOID_P EQUAL 4)
-- set(SPOTIFY_BLOB_ARCH 32)
-- else(CMAKE_SIZEOF_VOID_P EQUAL 4)
-- set(SPOTIFY_BLOB_ARCH 64)
-- endif(CMAKE_SIZEOF_VOID_P EQUAL 4)
--
-- install(
-- FILES ${CMAKE_BINARY_DIR}/clementine-spotifyblob
-- DESTINATION ${CMAKE_BINARY_DIR}/spotify/version${SPOTIFY_BLOB_VERSION}-${SPOTIFY_BLOB_ARCH}bit/
-- RENAME blob
-- )
--endif(LINUX)