summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobozzz2018-02-06 09:48:19 +0100
committerChocobozzz2018-02-06 09:48:19 +0100
commit3ed71d3f627f1ef4a1968be4de4469b9281a41d6 (patch)
tree960f3319de434c3be3f3eb9f4139b4f3b646fafc
parent51053cbe814db905cd422c92a503c19c5c2a6197 (diff)
downloadaur-3ed71d3f627f1ef4a1968be4de4469b9281a41d6.tar.gz
Fix compilation with crypto++
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--spotify_blob.patch78
3 files changed, 87 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e07288bd8f01..6add520d61a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Feb 19 13:54:44 UTC 2017
+# Tue Feb 6 08:48:03 UTC 2018
pkgbase = clementine-qt5-git
pkgdesc = Experimental Qt5 version of Clementine, a modern music player and library organiser.
- pkgver = 1.3.1.r231.g57d90ab
+ pkgver = 1.3.1.r497.g4c29c00e1
pkgrel = 1
url = http://www.clementine-player.org/
install = clementine.install
@@ -46,8 +46,10 @@ pkgbase = clementine-qt5-git
replaces = clementine-git
source = git+https://github.com/clementine-player/Clementine.git#branch=qt5
source = spotify_install.patch
+ source = spotify_blob.patch
sha256sums = SKIP
sha256sums = 05a438fb445790200258c536d396a6bda9df38a9b775d5259421376ec1878786
+ sha256sums = 440b7e0b9b70d3e379ec9404eb09c8eca584188d81269904fd57375671a74a8e
pkgname = clementine-qt5-git
diff --git a/PKGBUILD b/PKGBUILD
index 1abbc94d06e9..738b40247e6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Thanks to Adria Arrufat <swiftscythe@gmail.com>
pkgname=clementine-qt5-git
-pkgver=1.3.1.r359.g987aa20b9
+pkgver=1.3.1.r497.g4c29c00e1
pkgrel=1
pkgdesc="Experimental Qt5 version of Clementine, a modern music player and library organiser."
arch=('i686' 'x86_64')
@@ -27,8 +27,9 @@ optdepends=(
url="http://www.clementine-player.org/"
source=('git+https://github.com/clementine-player/Clementine.git#branch=qt5'
- 'spotify_install.patch')
-sha256sums=('SKIP' '05a438fb445790200258c536d396a6bda9df38a9b775d5259421376ec1878786')
+ 'spotify_install.patch' 'spotify_blob.patch')
+sha256sums=('SKIP' '05a438fb445790200258c536d396a6bda9df38a9b775d5259421376ec1878786'
+ '440b7e0b9b70d3e379ec9404eb09c8eca584188d81269904fd57375671a74a8e')
provides=('clementine')
conflicts=('clementine' 'clementine-lxqt' 'clementine-git')
@@ -42,7 +43,7 @@ pkgver() {
prepare() {
cd Clementine
- git revert -n 170c64cd8bef9df2ea88dd4f72eec641c250bcfd
+ git am --signoff -k < ../spotify_blob.patch
patch -Np0 -i ../spotify_install.patch
}
diff --git a/spotify_blob.patch b/spotify_blob.patch
new file mode 100644
index 000000000000..11924c79daa7
--- /dev/null
+++ b/spotify_blob.patch
@@ -0,0 +1,78 @@
+From e8c87242457ebd597c4f706b3b118afb39dbb742 Mon Sep 17 00:00:00 2001
+From: Chocobozzz <me@florianbigard.com>
+Date: Tue, 6 Feb 2018 08:45:48 +0100
+Subject: [PATCH] Revert "Link statically to libprotobuf from the spotifyblob"
+
+This reverts commit 170c64cd8bef9df2ea88dd4f72eec641c250bcfd.
+---
+ CMakeLists.txt | 2 --
+ ext/clementine-spotifyblob/CMakeLists.txt | 1 -
+ ext/libclementine-common/CMakeLists.txt | 1 +
+ ext/libclementine-remote/CMakeLists.txt | 1 -
+ ext/libclementine-tagreader/CMakeLists.txt | 1 -
+ 5 files changed, 1 insertion(+), 5 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 820b13851..3ec57df2b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -56,8 +56,6 @@ find_package(PkgConfig REQUIRED)
+ find_package(Protobuf REQUIRED)
+ find_package(FFTW3)
+
+-find_library(PROTOBUF_STATIC_LIBRARY libprotobuf.a libprotobuf)
+-
+ pkg_check_modules(CDIO libcdio)
+ pkg_check_modules(CHROMAPRINT REQUIRED libchromaprint)
+ pkg_search_module(CRYPTOPP cryptopp libcrypto++)
+diff --git a/ext/clementine-spotifyblob/CMakeLists.txt b/ext/clementine-spotifyblob/CMakeLists.txt
+index ca332dca1..30553bfc4 100644
+--- a/ext/clementine-spotifyblob/CMakeLists.txt
++++ b/ext/clementine-spotifyblob/CMakeLists.txt
+@@ -46,7 +46,6 @@ target_link_libraries(clementine-spotifyblob
+ ${QT_QTNETWORK_LIBRARY}
+ ${GSTREAMER_BASE_LIBRARIES}
+ ${GSTREAMER_APP_LIBRARIES}
+- ${PROTOBUF_STATIC_LIBRARY}
+ clementine-spotifyblob-messages
+ libclementine-common
+ )
+diff --git a/ext/libclementine-common/CMakeLists.txt b/ext/libclementine-common/CMakeLists.txt
+index 2cf31339b..56f46722c 100644
+--- a/ext/libclementine-common/CMakeLists.txt
++++ b/ext/libclementine-common/CMakeLists.txt
+@@ -36,6 +36,7 @@ add_library(libclementine-common STATIC
+
+ target_link_libraries(libclementine-common
+ ${QT_LIBRARIES}
++ ${PROTOBUF_LIBRARY}
+ ${TAGLIB_LIBRARIES}
+ ${CMAKE_THREAD_LIBS_INIT}
+ )
+diff --git a/ext/libclementine-remote/CMakeLists.txt b/ext/libclementine-remote/CMakeLists.txt
+index 5f860fbcd..f6fc7685a 100644
+--- a/ext/libclementine-remote/CMakeLists.txt
++++ b/ext/libclementine-remote/CMakeLists.txt
+@@ -11,7 +11,6 @@ add_library(libclementine-remote STATIC
+ )
+
+ target_link_libraries(libclementine-remote
+- ${PROTOBUF_LIBRARY}
+ libclementine-common
+ )
+
+diff --git a/ext/libclementine-tagreader/CMakeLists.txt b/ext/libclementine-tagreader/CMakeLists.txt
+index dd75473c9..ba9e3ff31 100644
+--- a/ext/libclementine-tagreader/CMakeLists.txt
++++ b/ext/libclementine-tagreader/CMakeLists.txt
+@@ -38,7 +38,6 @@ add_library(libclementine-tagreader STATIC
+ )
+
+ target_link_libraries(libclementine-tagreader
+- ${PROTOBUF_LIBRARY}
+ libclementine-common
+ )
+
+--
+2.16.1
+