summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobozzz2016-03-03 22:04:22 +0100
committerChocobozzz2016-03-03 22:04:22 +0100
commit8a67b1e8011ef3066755c9b6c5a0fa4938511cb1 (patch)
tree1017f38973c729abd1bc38435cc008d9ba564e40
parentbe01799abeffcda67af535a03054648f21d0e593 (diff)
downloadaur-8a67b1e8011ef3066755c9b6c5a0fa4938511cb1.tar.gz
Fix installation with spotify
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--spotify_install.patch21
3 files changed, 31 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e81f0b644f1..761e6f168443 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Mar 3 19:59:20 UTC 2016
+# Thu Mar 3 21:04:18 UTC 2016
pkgbase = clementine-qt5-git
pkgdesc = Experimental Qt5 version of Clementine, a modern music player and library organiser.
pkgver = 1.2.3.r1505.gabc6370
@@ -45,7 +45,9 @@ pkgbase = clementine-qt5-git
replaces = clementine-lxqt
replaces = clementine-git
source = git+https://github.com/clementine-player/Clementine.git#branch=qt5
+ source = spotify_install.patch
sha256sums = SKIP
+ sha256sums = 05a438fb445790200258c536d396a6bda9df38a9b775d5259421376ec1878786
pkgname = clementine-qt5-git
diff --git a/PKGBUILD b/PKGBUILD
index 0d948ea89324..a6b3edf7cdf4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,8 +26,9 @@ optdepends=(
)
url="http://www.clementine-player.org/"
-source=('git+https://github.com/clementine-player/Clementine.git#branch=qt5')
-sha256sums=('SKIP')
+source=('git+https://github.com/clementine-player/Clementine.git#branch=qt5'
+ 'spotify_install.patch')
+sha256sums=('SKIP' '05a438fb445790200258c536d396a6bda9df38a9b775d5259421376ec1878786')
provides=('clementine')
conflicts=('clementine' 'clementine-lxqt' 'clementine-git')
@@ -39,11 +40,13 @@ pkgver() {
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
+prepare() {
cd Clementine
git revert -n 170c64cd8bef9df2ea88dd4f72eec641c250bcfd
- cd ../
+ patch -Np0 -i ../spotify_install.patch
+}
+build() {
mkdir -p build
cd build
diff --git a/spotify_install.patch b/spotify_install.patch
new file mode 100644
index 000000000000..3418beef1283
--- /dev/null
+++ b/spotify_install.patch
@@ -0,0 +1,21 @@
+--- ext/clementine-spotifyblob/CMakeLists.txt 2016-03-03 21:42:28.483811815 +0100
++++ ext/clementine-spotifyblob/CMakeLists.txt.new 2016-03-03 21:42:56.237145560 +0100
+@@ -62,18 +62,3 @@
+ RUNTIME DESTINATION bin
+ )
+ endif(NOT APPLE)
+-
+-if(LINUX)
+- # Versioned name of the blob
+- if(CMAKE_SIZEOF_VOID_P EQUAL 4)
+- set(SPOTIFY_BLOB_ARCH 32)
+- else(CMAKE_SIZEOF_VOID_P EQUAL 4)
+- set(SPOTIFY_BLOB_ARCH 64)
+- endif(CMAKE_SIZEOF_VOID_P EQUAL 4)
+-
+- install(
+- FILES ${CMAKE_BINARY_DIR}/clementine-spotifyblob
+- DESTINATION ${CMAKE_BINARY_DIR}/spotify/version${SPOTIFY_BLOB_VERSION}-${SPOTIFY_BLOB_ARCH}bit/
+- RENAME blob
+- )
+-endif(LINUX)