summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTGS2017-01-09 09:45:18 -0500
committerTGS2017-01-09 09:45:18 -0500
commit75c9ece4ddde81de9b23e7c2dc6edffdd6d64854 (patch)
tree8d7122fcd894f93afa784df20f7567e13b9c1c92
parent59c94e1837221e993e41fb4353d688ec2e522569 (diff)
downloadaur-75c9ece4ddde81de9b23e7c2dc6edffdd6d64854.tar.gz
Unfortunately, the makefile doesn't let you specify a destdir, we must move the binary or create a separate fork
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f14f27426722..64f43ee99168 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = clevo-indicator-git
pkgdesc = Command-line fan control utility for Clevo laptops
pkgver = r17.fa0a7af
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/SkyLandTW/clevo-indicator
install = clevo-indicator-git.install
changelog = README.md
diff --git a/PKGBUILD b/PKGBUILD
index f5b4eb7f926b..f916bb2819a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
# Maintainer: Tech Guy Software <techguy100official at gmail dot com>
pkgname=clevo-indicator-git
pkgver=r17.fa0a7af
-pkgrel=3
+pkgrel=4
#epoch=
pkgdesc="Command-line fan control utility for Clevo laptops"
arch=('x86_64')
@@ -50,15 +50,21 @@ build() {
}
package() {
- # make from source and install to /usr/bin
+ # make from source and install to /usr/local/bin
cd "$pkgname"
- make DESTDIR="$pkgdir/" install
-
+ make install
+
+ # the package's makefile installs to /usr/local/bin, we don't want that, there is no option other than to move it or create a separate fork of the project
+ # https://bbs.archlinux.org/viewtopic.php?id=158031
+ # per the AUR package etiquette, /usr/bin is preferred
+
# move clevo-indicator binary to /usr/bin for execution
# in command line
-
- #echo "--> Removing existing binaries..."
- #sudo rm -f "/usr/bin/clevo-indicator"
+ echo "--> Removing existing binaries..."
+ sudo rm -f "/usr/bin/clevo-indicator"
+
+ echo "--> Moving built binary to /usr/bin..."
+ sudo mv /usr/local/bin/clevo-indicator /usr/bin/
echo "--> Installation successful! Run the fan control utility using the command \"clevo-indicator\" as the root user."
}