summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTGS2016-12-11 02:11:41 -0500
committerTGS2016-12-11 02:11:41 -0500
commitb7d81d439bd8c7f38c2a7a5638c241708588d043 (patch)
tree7a21381f3fb4438681dfe03b974c081d602ebc27
downloadaur-b7d81d439bd8c7f38c2a7a5638c241708588d043.tar.gz
Add first release of clevo-indicator-git to AUR
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD63
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a01e3848c638
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = clevo-indicator-git
+ pkgdesc = Command-line fan control utility for Clevo laptops
+ pkgver = r17.fa0a7af
+ pkgrel = 1
+ url = https://github.com/SkyLandTW/clevo-indicator
+ arch = x86_64
+ license = custom:Unlicense
+ makedepends = git
+ depends = libappindicator-gtk3
+ source = clevo-indicator-git::git+https://github.com/SkyLandTW/clevo-indicator.git
+ md5sums = SKIP
+
+pkgname = clevo-indicator-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74389ab9ae4d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# PKGBUILD prototype location: /usr/share/pacman/PKGBUILD.proto
+# Example: https://github.com/archlinuxarm/PKGBUILDs/blob/master/aur/libcrossguid-git/PKGBUILD
+
+# Maintainer: Tech Guy Software <techguy100official at gmail dot com>
+pkgname=clevo-indicator-git
+pkgver=r17.fa0a7af
+pkgrel=1
+#epoch=
+pkgdesc="Command-line fan control utility for Clevo laptops"
+arch=('x86_64')
+url="https://github.com/SkyLandTW/clevo-indicator"
+license=('custom:Unlicense')
+#groups=()
+depends=('libappindicator-gtk3')
+makedepends=('git')
+#provides=()
+#conflicts=()
+#replaces=()
+#backup=()
+#options=()
+#install=
+#changelog=
+source=("${pkgname%}::git+https://github.com/SkyLandTW/clevo-indicator.git")
+md5sums=('SKIP')
+#noextract=()
+#validpgpkeys=()
+
+pkgver() {
+ cd "$srcdir"/$pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$pkgname"
+ #patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
+}
+
+build() {
+ cd "$pkgname"
+ #./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+ echo "--> Moving files to /usr/bin..."
+ sudo mv "/usr/local/bin/clevo-indicator" "/usr/bin/$pkgname"
+ echo "--> Success! Run the fan control utility using the command \"clevo-indicator\" as the root user."
+}
+
+makepkgclean() {
+ echo "--> Cleaning up files created by makepkg..."
+ makepkg -code
+ echo "--> Removing command-line script from directory..."
+ cd "/usr/local/bin"
+ sudo rm -rf "$pkgname"
+}