summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhys Perry2022-01-05 11:34:22 +0000
committerRhys Perry2022-01-05 11:34:22 +0000
commitc4d4211a96e5ca89f73fe8cdd461f2e4abe13cb9 (patch)
tree9f037425cbcba89ff249eb3866d41a503eb3a3a1
downloadaur-c4d4211a96e5ca89f73fe8cdd461f2e4abe13cb9.tar.gz
Because YOU, yes you, should be proud of yourself
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f9fcf95898d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cli-pride-flags
+ pkgdesc = Displays pride flags in your terminal~
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/ExperiBass/cli-pride-flags
+ arch = any
+ license = GPL3
+ makedepends = npm
+ depends = nodejs-chalk
+ depends = nodejs
+ noextract = cli-pride-flags-1.0.2.tgz
+ source = https://registry.npmjs.org/cli-pride-flags/-/cli-pride-flags-1.0.2.tgz
+ sha256sums = cf5950447e57760ec0375eac3f98afd96258e0b48f6ffff043239351d97c1c35
+
+pkgname = cli-pride-flags
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..990f20da5015
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Rhys Perry <rhysperry111@gmail.com>
+
+pkgname=cli-pride-flags
+pkgver=1.0.2
+pkgrel=1
+pkgdesc='Displays pride flags in your terminal~'
+arch=('any')
+url='https://github.com/ExperiBass/cli-pride-flags'
+license=('GPL3')
+depends=('nodejs-chalk' 'nodejs')
+makedepends=('npm')
+source=("https://registry.npmjs.org/${pkgname}/-/${pkgname}-${pkgver}.tgz")
+noextract=("${pkgname}-${pkgver}.tgz")
+sha256sums=('cf5950447e57760ec0375eac3f98afd96258e0b48f6ffff043239351d97c1c35')
+
+package() {
+ npm install -g --prefix "${pkgdir}/usr" "${srcdir}/${pkgname}-${pkgver}.tgz"
+
+ # npm gives ownership of ALL FILES to build user
+ # https://bugs.archlinux.org/task/63396
+ chown -R root:root "${pkgdir}"
+}