summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordpayne2016-12-14 19:35:25 -0800
committerdpayne2016-12-14 19:35:25 -0800
commitc0f20c9a3f9b87a42acbaa4af5be2e43a995b06b (patch)
tree3fee637ab806af92e5a77dc324a491ec5885e045
parenta518a4a55bca3740c9a52c8a8b014e37edbdf884 (diff)
downloadaur-c0f20c9a3f9b87a42acbaa4af5be2e43a995b06b.tar.gz
Updating to version 1.4
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6e1bee0af2b..aed133815ca7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Mon Feb 15 19:28:33 UTC 2016
pkgbase = cli-visualizer
pkgdesc = A cli visualizer for mpd
- pkgver = 1.1
- pkgrel = 2
+ pkgver = 1.4
+ pkgrel = 4
url = https://github.com/dpayne/cli-visualizer/
install = cli-visualizer.install
arch = i686
@@ -11,11 +9,11 @@ pkgbase = cli-visualizer
license = MIT
makedepends = git
makedepends = fftw
- makedepends = pkg-config
depends = ncurses
depends = fftw
- source = https://github.com/dpayne/cli-visualizer/archive/v1.1.tar.gz
- sha256sums = 13ae8ce89d3d2e41524a42dbb14343b951701f44650ea5a977c3311cb96a113f
+ conflicts = vis
+ source = https://github.com/dpayne/cli-visualizer/archive/1.4.tar.gz
+ sha256sums = fe8475170fa766c41c38e6c1b865cc77f8d4579deeffeaa1106b1a54a6107aee
pkgname = cli-visualizer
diff --git a/PKGBUILD b/PKGBUILD
index cc9a03dda4d6..11867f96b168 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,26 @@
# Maintainer: dpayne <darby.payne@gmail.com>
pkgname="cli-visualizer"
-pkgver=1.2
-pkgrel=3
+pkgver=1.4
+pkgrel=4
pkgdesc="A cli visualizer for mpd"
arch=('i686' 'x86_64')
url="https://github.com/dpayne/cli-visualizer/"
license=('MIT')
depends=('ncurses' 'fftw')
-makedepends=('git' 'fftw' 'pkg-config')
-conflicts=()
+makedepends=('git' 'fftw')
+conflicts=('vis')
install=${pkgname}.install
-source=('https://github.com/dpayne/cli-visualizer/archive/1.2.tar.gz')
-sha256sums=('9e23d13b038bf00bb1261523b4e030e978aa29b5c919c4e96b413ea01e7ca2c3')
+source=('https://github.com/dpayne/cli-visualizer/archive/1.4.tar.gz')
+sha256sums=('fe8475170fa766c41c38e6c1b865cc77f8d4579deeffeaa1106b1a54a6107aee')
build() {
- cd $pkgname-$pkgver || exit
+ cd $pkgname-$pkgver
make
}
package() {
- cd $pkgname-$pkgver || exit
+ cd $pkgname-$pkgver
install -Dm755 build/vis "$pkgdir/usr/bin/vis"
install -Dm644 examples/blue "$pkgdir"/usr/share/doc/"$pkgname"/blue
install -Dm644 examples/config "$pkgdir"/usr/share/doc/"$pkgname"/config