summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Araujo2020-10-26 13:15:13 +0000
committerDaniel Araujo2020-10-26 13:15:13 +0000
commitb5ab1cf03b47cf29a300620d2580522c3ca6e0f6 (patch)
tree63534792797f245b1931e674db6e1945c3ebcfd1
parent853e498e85d34a3799d31e93b0e5486f5daaba4b (diff)
downloadaur-b5ab1cf03b47cf29a300620d2580522c3ca6e0f6.tar.gz
Update to version 1.1.0
This version drops autotools and introduces cmake.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c73f15b3ab2d..ac1a0b0bc7f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = click4ever
pkgdesc = An auto clicker for Linux running X11. A program that generates a lot of mouse clicks per second at the current position of the mouse until you move it away.
- pkgver = 1.0.2
- pkgrel = 3
+ pkgver = 1.1.0
+ pkgrel = 1
url = https://github.com/daniel-araujo/click4ever
arch = x86_64
license = GPL3
makedepends = git
- makedepends = autoconf
- makedepends = automake
+ makedepends = cmake
depends = xdotool
- source = git+https://github.com/daniel-araujo/click4ever.git#tag=v1.0.2
+ source = git+https://github.com/daniel-araujo/click4ever.git#tag=v1.1.0
md5sums = SKIP
pkgname = click4ever
diff --git a/PKGBUILD b/PKGBUILD
index d5b5e865fa62..6c3e6afdd65e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
# Maintainer: Daniel Araujo <contact@daniel-araujo.pt>
pkgname='click4ever'
-pkgver='1.0.2'
-pkgrel='3'
+pkgver='1.1.0'
+pkgrel='1'
pkgdesc='An auto clicker for Linux running X11. A program that generates a lot of mouse clicks per second at the current position of the mouse until you move it away.'
url='https://github.com/daniel-araujo/click4ever'
arch=('x86_64')
license=('GPL3')
depends=('xdotool')
-makedepends=('git' 'autoconf' 'automake')
-source=("git+https://github.com/daniel-araujo/click4ever.git#tag=v1.0.2")
+makedepends=('git' 'cmake')
+source=("git+https://github.com/daniel-araujo/click4ever.git#tag=v1.1.0")
md5sums=('SKIP')
build() {
- cd click4ever
- autoreconf -i
- ./configure --prefix=/usr
- make
+ mkdir -p click4ever/build
+ cd click4ever/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr --config Release ..
}
package() {
- cd click4ever
+ cd click4ever/build
make DESTDIR="$pkgdir/" install
}