summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortydell2018-04-04 02:21:14 +0200
committertydell2018-04-04 02:21:14 +0200
commit7b36e97086e85502e4e6f8253cd0b9c00a2a064e (patch)
treedb6e7de56de85310b778e871ed556a9e3ff61073
parenta0e916d223b24d2d14f875a4d628e34885c4c076 (diff)
downloadaur-7b36e97086e85502e4e6f8253cd0b9c00a2a064e.tar.gz
Updated package, cookiecutter needs to be installed by pip2 due to python2 used by clickable
-rw-r--r--.SRCINFO7
-rwxr-xr-xPKGBUILD13
-rwxr-xr-xclickable.install12
3 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe1e51efdcc7..6850e44ed0b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = clickable
pkgdesc = Compile, build, and deploy Ubuntu Touch click packages all from the command line.
- pkgver = 169.6eae4ca
+ pkgver = 171.df08be6
pkgrel = 1
url = https://github.com/bhdouglass/clickable
install = clickable.install
@@ -8,8 +8,11 @@ pkgbase = clickable
arch = x86_64
license = GPL3
makedepends = git
+ depends = python
depends = docker
- depends = python-cookiecutter
+ depends = pip2pkgbuild
+ optdepends = android-sdk-platform-tools
+ optdepends = lxd
provides = clickable
conflicts = clickable
source = git+https://github.com/bhdouglass/clickable.git
diff --git a/PKGBUILD b/PKGBUILD
index 057539f91954..010c594a0dbb 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Contributor: Brian Douglass <https://github.com/bhdouglass/, http://bhdouglass.com/>
pkgname=clickable
-pkgver=169.6eae4ca
+pkgver=171.df08be6
pkgrel=1
_gitname=clickable
pkgdesc='Compile, build, and deploy Ubuntu Touch click packages all from the command line.'
arch=('i686' 'x86_64')
url='https://github.com/bhdouglass/clickable'
license=('GPL3')
-depends=('docker' 'python-cookiecutter')
-optdepends=()
+depends=('python' 'docker' 'pip2pkgbuild')
+optdepends=('android-sdk-platform-tools' 'lxd')
makedepends=('git')
provides=("${pkgname%}")
conflicts=("${pkgname%}")
@@ -25,11 +25,8 @@ pkgver() {
package() {
-install -dm755 ${pkgdir}/opt
-
-rm -R ${srcdir}/${pkgname}/.git*
-cp -R ${srcdir}/${pkgname} ${pkgdir}/opt/${pkgname}
-
+mkdir -p $pkgdir/usr/bin
+install -m755 -t $pkgdir/usr/bin $srcdir/$pkgname/clickable
}
# vim: ts=2 sw=2 et:
diff --git a/clickable.install b/clickable.install
index 1180199cacba..44a49038f720 100755
--- a/clickable.install
+++ b/clickable.install
@@ -3,13 +3,13 @@ post_install() {
glib-compile-schemas usr/share/glib-2.0/schemas
gtk-update-icon-cache -ftq usr/share/icons/hicolor
- echo "To finish installation you have to add clickable to your PATH:"
- echo ' echo "export PATH=\$PATH:\/opt/clickable" >> ~/.bashrc'
- echo "Read the new .bashrc file:"
- echo " source ~/.bashrc"
- echo "Configure docker for clickable:"
+ echo " "
+ echo "After installation you need to configure docker for clickable:"
echo " clickable setup-docker"
-
+ echo "and install cookiecutter package"
+ echo " pip2 install --user cookiecutter"
+ echo " "
+
}
post_upgrade() {