summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkmeaw2017-06-18 18:34:23 +0300
committerkmeaw2017-06-18 18:34:23 +0300
commit4bcf9d84a9a8f7fc6ff14f5cb6a65d2f54081302 (patch)
treed182454b0c3f8888721b61f66c1cfb8f0c88adfc
parent758bd9b0c59fecdd5bb0b46904401ca53b148a39 (diff)
downloadaur-4bcf9d84a9a8f7fc6ff14f5cb6a65d2f54081302.tar.gz
Use gcc6 for building clickhouse
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
-rw-r--r--clickhouse-mongodb.patch18
-rw-r--r--re2-length.patch26
4 files changed, 40 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d2f0d2038c7..063abf1f69cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = clickhouse
pkgdesc = An open-source column-oriented database management system that allows generating analytical data reports in real time
- pkgver = 1.1.54231
+ pkgver = 1.1.54236
pkgrel = 1
url = https://clickhouse.yandex/
install = clickhouse.install
@@ -17,14 +17,12 @@ pkgbase = clickhouse
backup = etc/clickhouse-client/config.xml
backup = etc/clickhouse-server/config.xml
backup = etc/clickhouse-server/users.xml
- source = https://github.com/yandex/ClickHouse/archive/v1.1.54231-stable.tar.gz
+ source = https://github.com/yandex/ClickHouse/archive/v1.1.54236-stable.tar.gz
source = clickhouse-server.service
- source = clickhouse-mongodb.patch
- source = https://gist.github.com/kmeaw/bf6703543421abb68e0c524c1f48026f/raw/a2afde429cd795103fc2511ba31ada98c31d7b5d/clickhouse-lz4.patch
- md5sums = 32f49d54c8482ff1e17e13f33514eaa3
+ source = re2-length.patch
+ md5sums = 78083caddfdc9b2fead32d11ea8609b8
md5sums = f9f5663b0a9a58e99f481efe9d193e85
- md5sums = 127966b32939673fa0b695f0360555b0
- md5sums = ba6a4ec1c6b9040f1ff27bb18d998fb7
+ md5sums = 143f0146c3ef3a6832191fba352b70c4
pkgname = clickhouse
diff --git a/PKGBUILD b/PKGBUILD
index b19aa4cf2fb9..d6e445f5a5b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,30 @@
# Maintainer: Dmitry Bilunov <kmeaw@yandex-team.ru>
pkgname=clickhouse
-pkgver=1.1.54231
+pkgver=1.1.54236
pkgrel=1
pkgdesc='An open-source column-oriented database management system that allows generating analytical data reports in real time'
arch=('i686' 'x86_64')
url='https://clickhouse.yandex/'
license=('Apache')
depends=('ncurses' 'readline' 'unixodbc' 'termcap')
-makedepends=('poco' 'cmake' 'gcc>=6.2')
+makedepends=('poco' 'cmake' 'gcc6')
source=(https://github.com/yandex/ClickHouse/archive/v$pkgver-stable.tar.gz
clickhouse-server.service
- clickhouse-mongodb.patch
- https://gist.github.com/kmeaw/bf6703543421abb68e0c524c1f48026f/raw/a2afde429cd795103fc2511ba31ada98c31d7b5d/clickhouse-lz4.patch)
-md5sums=('32f49d54c8482ff1e17e13f33514eaa3'
+ re2-length.patch)
+md5sums=('78083caddfdc9b2fead32d11ea8609b8'
'f9f5663b0a9a58e99f481efe9d193e85'
- '127966b32939673fa0b695f0360555b0'
- 'ba6a4ec1c6b9040f1ff27bb18d998fb7')
+ '143f0146c3ef3a6832191fba352b70c4')
backup=('etc/clickhouse-client/config.xml' 'etc/clickhouse-server/config.xml' 'etc/clickhouse-server/users.xml')
install=$pkgname.install
build() {
cd ClickHouse-$pkgver-stable
sed -e 's/mysqlxx common\(.*\) \(\${Z_LIB}\)/mysqlxx \2 common\1/' -i libs/libmysqlxx/CMakeLists.txt
- patch -p1 < ../clickhouse-mongodb.patch
- patch -p1 < ../clickhouse-lz4.patch
- cmake -D CMAKE_BUILD_TYPE:STRING=Release -D USE_STATIC_LIBRARIES:BOOL=False -D ENABLE_TESTS:BOOL=False -D UNBUNDLED:BOOL=True .
+ patch -p1 < ../re2-length.patch
+ export CC=gcc-6
+ export CXX=g++-6
+ cmake -D CMAKE_BUILD_TYPE:STRING=Release -D USE_STATIC_LIBRARIES:BOOL=False -D ENABLE_TESTS:BOOL=False -D UNBUNDLED:BOOL=False .
make clickhouse
}
diff --git a/clickhouse-mongodb.patch b/clickhouse-mongodb.patch
deleted file mode 100644
index 84dd15e93e69..000000000000
--- a/clickhouse-mongodb.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/dbms/src/Dictionaries/MongoDBDictionarySource.cpp 2017-05-16 13:59:48.153072479 +0300
-+++ b/dbms/src/Dictionaries/MongoDBDictionarySource.cpp 2017-05-16 14:00:07.566365200 +0300
-@@ -32,6 +32,7 @@
- static const size_t max_block_size = 8192;
-
-
-+#if POCO_VERSION < 0x01070800
- /// See https://pocoproject.org/forum/viewtopic.php?f=10&t=6326&p=11426&hilit=mongodb+auth#p11485
- static void authenticate(Poco::MongoDB::Connection & connection,
- const std::string & database, const std::string & user, const std::string & password)
-@@ -117,6 +118,7 @@
- }
- }
- }
-+#endif
-
-
- MongoDBDictionarySource::MongoDBDictionarySource(
diff --git a/re2-length.patch b/re2-length.patch
new file mode 100644
index 000000000000..c1f0bf3c1046
--- /dev/null
+++ b/re2-length.patch
@@ -0,0 +1,26 @@
+From e6a76059d371c11dae51648e348f9d9f41d3ba96 Mon Sep 17 00:00:00 2001
+From: Dmitry Bilunov <kmeaw@yandex-team.ru>
+Date: Tue, 6 Jun 2017 13:10:33 +0300
+Subject: [PATCH 1/1] re2: respect (possibly signed) return type of
+ StringPiece::length()
+
+---
+ dbms/src/Functions/FunctionsStringSearch.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/dbms/src/Functions/FunctionsStringSearch.cpp b/dbms/src/Functions/FunctionsStringSearch.cpp
+index daf595f74..a3b335d6b 100644
+--- a/dbms/src/Functions/FunctionsStringSearch.cpp
++++ b/dbms/src/Functions/FunctionsStringSearch.cpp
+@@ -630,7 +630,7 @@ struct ReplaceRegexpImpl
+ {
+ re2_st::StringPiece matches[max_captures];
+
+- int start_pos = 0;
++ decltype(input.length()) start_pos = 0;
+ while (start_pos < input.length())
+ {
+ /// If no more replacements possible for current string
+--
+2.12.2
+