summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkmeaw2018-01-22 19:44:48 +0300
committerkmeaw2018-01-22 19:44:48 +0300
commitb642f325dfea100dcce446c3d29567f271eab23d (patch)
treefb93ee24b1da153dfb944706dc264f2b12d272d0
parent0bec3a5c9a53f4c2d10eac12352052926edd30b3 (diff)
downloadaur-b642f325dfea100dcce446c3d29567f271eab23d.tar.gz
Use ClickHouse-Extras/poco
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD10
3 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e514f41ed24..f109d695cb6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = clickhouse
pkgdesc = An open-source column-oriented database management system that allows generating analytical data reports in real time
pkgver = 1.1.54337
- pkgrel = 1
+ pkgrel = 2
url = https://clickhouse.yandex/
install = clickhouse.install
arch = i686
@@ -16,7 +16,6 @@ pkgbase = clickhouse
depends = capnproto
depends = re2
depends = gtest
- depends = poco
backup = etc/clickhouse-client/config.xml
backup = etc/clickhouse-server/config.xml
backup = etc/clickhouse-server/users.xml
@@ -27,6 +26,7 @@ pkgbase = clickhouse
source = https://github.com/ClickHouse-Extras/zookeeper/archive/d2f05a6.tar.gz
source = https://github.com/facebook/zstd/archive/f4340f4.tar.gz
source = https://github.com/Dead2/zlib-ng/archive/e07a52d.tar.gz
+ source = https://github.com/ClickHouse-Extras/poco/archive/81d4fdf.tar.gz
source = clickhouse-server.service
source = re2-length.patch
source = libunwind.patch
@@ -37,6 +37,7 @@ pkgbase = clickhouse
md5sums = 6636ab50e66d1c0a1e05d83ed6154bdc
md5sums = e3212525a38d6cc38e26979a10c174ed
md5sums = 87676f8d7fcdea908476029f92b8103f
+ md5sums = 1bc2bbf8b5c26f6685cca8f8b7525d4c
md5sums = f9f5663b0a9a58e99f481efe9d193e85
md5sums = 143f0146c3ef3a6832191fba352b70c4
md5sums = f3f60b75abf8d6f21de74db6e88e1e7b
diff --git a/.gitignore b/.gitignore
index 2a900c699ae8..09754df538cd 100644
--- a/.gitignore
+++ b/.gitignore
@@ -9,3 +9,4 @@ d2f05a6.tar.gz
f4340f4.tar.gz
e07a52d.tar.gz
*.part
+81d4fdf.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 9c8f7c08e481..1613e3e4d168 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=clickhouse
pkgver=1.1.54337
-pkgrel=1
+pkgrel=2
pkgdesc='An open-source column-oriented database management system that allows generating analytical data reports in real time'
arch=('i686' 'x86_64')
url='https://clickhouse.yandex/'
license=('Apache')
-depends=('ncurses' 'readline' 'unixodbc' 'termcap' 'double-conversion' 'capnproto' 're2' 'gtest' 'poco')
+depends=('ncurses' 'readline' 'unixodbc' 'termcap' 'double-conversion' 'capnproto' 're2' 'gtest')
makedepends=('cmake')
source=(https://github.com/yandex/ClickHouse/archive/v$pkgver-stable.tar.gz
https://github.com/google/cctz/archive/4f9776a.tar.gz
@@ -17,6 +17,7 @@ source=(https://github.com/yandex/ClickHouse/archive/v$pkgver-stable.tar.gz
https://github.com/ClickHouse-Extras/zookeeper/archive/d2f05a6.tar.gz
https://github.com/facebook/zstd/archive/f4340f4.tar.gz
https://github.com/Dead2/zlib-ng/archive/e07a52d.tar.gz
+ https://github.com/ClickHouse-Extras/poco/archive/81d4fdf.tar.gz
clickhouse-server.service
re2-length.patch
libunwind.patch)
@@ -27,6 +28,7 @@ md5sums=('e6a1820e3267a39f831223f46ef42d64'
'6636ab50e66d1c0a1e05d83ed6154bdc'
'e3212525a38d6cc38e26979a10c174ed'
'87676f8d7fcdea908476029f92b8103f'
+ '1bc2bbf8b5c26f6685cca8f8b7525d4c'
'f9f5663b0a9a58e99f481efe9d193e85'
'143f0146c3ef3a6832191fba352b70c4'
'f3f60b75abf8d6f21de74db6e88e1e7b')
@@ -36,7 +38,6 @@ install=$pkgname.install
prepare() {
cd ClickHouse-$pkgver-stable
sed -e 's/mysqlxx common\(.*\) \(\${Z_LIB}\)/mysqlxx \2 common\1/' -i libs/libmysqlxx/CMakeLists.txt
- sed -e '/FindODBC/s/^/#/' -i CMakeLists.txt
patch -p1 < ../re2-length.patch
patch -p1 < ../libunwind.patch
mkdir -p contrib/cctz contrib/librdkafka contrib/lz4 contrib/zookeeper contrib/zstd
@@ -46,6 +47,7 @@ prepare() {
mv ../zookeeper-d2f05a6*/* contrib/zookeeper/
mv ../zstd-f4340f4*/* contrib/zstd/
mv ../zlib-ng-e07a52d*/* contrib/zlib-ng/
+ mv ../poco-81d4fdf*/* contrib/poco/
for dir in contrib/*/; do
rmdir $dir &> /dev/null || true
done
@@ -53,7 +55,7 @@ prepare() {
build() {
cd ClickHouse-$pkgver-stable
- cmake -D CMAKE_BUILD_TYPE:STRING=Release -D USE_STATIC_LIBRARIES:BOOL=False -D ENABLE_TESTS:BOOL=False -D UNBUNDLED:BOOL=False -D USE_INTERNAL_DOUBLE_CONVERSION_LIBRARY:BOOL=False -D USE_INTERNAL_CAPNP_LIBRARY:BOOL=False -D USE_INTERNAL_POCO_LIBRARY:BOOL=False .
+ cmake -D CMAKE_BUILD_TYPE:STRING=Release -D USE_STATIC_LIBRARIES:BOOL=False -D ENABLE_TESTS:BOOL=False -D UNBUNDLED:BOOL=False -D USE_INTERNAL_DOUBLE_CONVERSION_LIBRARY:BOOL=False -D USE_INTERNAL_CAPNP_LIBRARY:BOOL=False -D USE_INTERNAL_POCO_LIBRARY:BOOL=True .
make clickhouse
}