summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Mezentsev2020-05-08 15:46:54 +0300
committerSergey Mezentsev2020-05-08 15:53:32 +0300
commit88efebf091fac14bab016117e628b9db10adc9c8 (patch)
treea234054f3161bf78677b687859a383ba54e34bc4
downloadaur-88efebf091fac14bab016117e628b9db10adc9c8.tar.gz
init
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD66
-rw-r--r--clickhouse-server.service20
-rw-r--r--clickhouse.sysusers2
4 files changed, 122 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17effcafd9b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = clickhouse-bin
+ pkgdesc = ClickHouse is a fast open-source OLAP database management system
+ pkgver = 20.3.8.53
+ pkgrel = 1
+ url = https://clickhouse.tech/
+ arch = x86_64
+ license = Apache
+ provides = clickhouse
+ source = https://repo.yandex.ru/clickhouse/tgz/stable/clickhouse-client-20.3.8.53.tgz
+ source = https://repo.yandex.ru/clickhouse/tgz/stable/clickhouse-common-static-20.3.8.53.tgz
+ source = https://repo.yandex.ru/clickhouse/tgz/stable/clickhouse-server-20.3.8.53.tgz
+ source = clickhouse.sysusers
+ source = clickhouse-server.service
+ sha512sums = 80637af63fabb626782d5fce53b780e48029cc666c044c91860da271d62cb35300583dbd389061a3ac173be6a5c601667941137a1e5c99549faf21d7065603e1
+ sha512sums = ee4b09de39cc25dbf1692cb13f456cb258ed0eafe014a5da87ba5e847392719ba141ab1fd5447eed7fafbdb49c985bec4a4bc6ed7dec89c137bd01ac3761925f
+ sha512sums = 0f0d6f950cfa87beda90b643b6477992a73b88a8c88ef80480257da8a007436e449d46e07e81145b0c8fbbf7e6229d5e9e255d376c44f65bf29e8a6c722cf3af
+ sha512sums = 70af4456ded1a1bb5cf29d2d3b29086aedc7875ef673e8817f389243f0c79eb491c9ce715b94542cbe16eb7489d97411ff0ab4a1a7f6c9b9120c659b87ea25b7
+ sha512sums = f70fb1fc8d26e1d6c8b4f5c808b373d464cd20ace363cfd735703d1af0f6ec6196a0c7c905d804fad789eb51acab4896397e70b64a0b61cdcd7457a6694fc4b3
+
+pkgname = clickhouse-server-bin
+ pkgdesc = ClickHouse server and default configuration.
+ depends = clickhouse-common-static-bin
+ backup = etc/clickhouse-server/config.xml
+ backup = etc/clickhouse-server/users.xml
+
+pkgname = clickhouse-common-static-bin
+ pkgdesc = ClickHouse compiled binary files.
+ backup = etc/security/limits.d/clickhouse.conf
+
+pkgname = clickhouse-client-bin
+ pkgdesc = ClickHouse client and other client-related tools.
+ depends = clickhouse-common-static-bin
+ backup = etc/clickhouse-client/config.xml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c1a2b373592
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Sergey Mezentsev <thebits@yandex.ru>
+pkgbase='clickhouse-bin'
+pkgname=('clickhouse-server-bin' 'clickhouse-common-static-bin' 'clickhouse-client-bin')
+pkgver=20.3.8.53
+pkgrel=1
+provides=('clickhouse')
+pkgdesc="ClickHouse is a fast open-source OLAP database management system"
+arch=('x86_64')
+url="https://clickhouse.tech/"
+license=('Apache')
+source=(
+ "https://repo.yandex.ru/clickhouse/tgz/stable/clickhouse-client-$pkgver.tgz"
+ "https://repo.yandex.ru/clickhouse/tgz/stable/clickhouse-common-static-$pkgver.tgz"
+ "https://repo.yandex.ru/clickhouse/tgz/stable/clickhouse-server-$pkgver.tgz"
+ "clickhouse.sysusers"
+ "clickhouse-server.service"
+)
+sha512sums=(
+ # client
+ '80637af63fabb626782d5fce53b780e48029cc666c044c91860da271d62cb35300583dbd389061a3ac173be6a5c601667941137a1e5c99549faf21d7065603e1'
+ # common
+ 'ee4b09de39cc25dbf1692cb13f456cb258ed0eafe014a5da87ba5e847392719ba141ab1fd5447eed7fafbdb49c985bec4a4bc6ed7dec89c137bd01ac3761925f'
+ # server
+ '0f0d6f950cfa87beda90b643b6477992a73b88a8c88ef80480257da8a007436e449d46e07e81145b0c8fbbf7e6229d5e9e255d376c44f65bf29e8a6c722cf3af'
+ # sysusers
+ '70af4456ded1a1bb5cf29d2d3b29086aedc7875ef673e8817f389243f0c79eb491c9ce715b94542cbe16eb7489d97411ff0ab4a1a7f6c9b9120c659b87ea25b7'
+ # service
+ 'f70fb1fc8d26e1d6c8b4f5c808b373d464cd20ace363cfd735703d1af0f6ec6196a0c7c905d804fad789eb51acab4896397e70b64a0b61cdcd7457a6694fc4b3'
+)
+
+
+package_clickhouse-client-bin() {
+ depends=('clickhouse-common-static-bin')
+ backup=('etc/clickhouse-client/config.xml')
+ pkgdesc="ClickHouse client and other client-related tools."
+
+ cd "$pkgname-$pkgver"
+ cp -r etc usr $pkgdir
+}
+
+package_clickhouse-common-static-bin() {
+ # options and directives overrides
+ pkgdesc="ClickHouse compiled binary files."
+ backup=('etc/security/limits.d/clickhouse.conf')
+
+ cd "$pkgname-$pkgver"
+ cp -r etc usr $pkgdir
+}
+
+package_clickhouse-server-bin() {
+ # options and directives overrides
+ pkgdesc="ClickHouse server and default configuration."
+ depends=('clickhouse-common-static-bin')
+ backup=(
+ 'etc/clickhouse-server/config.xml'
+ 'etc/clickhouse-server/users.xml'
+ )
+
+ cd "$pkgname-$pkgver"
+ cp -r usr "$pkgdir/"
+ cp -r lib "$pkgdir/usr"
+ mkdir -p "$pkgdir/etc/clickhouse-server"
+ cp -r etc/clickhouse-server "$pkgdir/etc"
+ install -D "$srcdir/clickhouse.sysusers" "${pkgdir}/usr/lib/sysusers.d/clickhouse.conf"
+ install -D "$srcdir/clickhouse-server.service" "${pkgdir}/usr/lib/systemd/system/clickhouse-server.service"
+}
diff --git a/clickhouse-server.service b/clickhouse-server.service
new file mode 100644
index 000000000000..36e4bf7a267c
--- /dev/null
+++ b/clickhouse-server.service
@@ -0,0 +1,20 @@
+[Unit]
+Description=ClickHouse Server (analytic DBMS for big data)
+Requires=network-online.target
+After=network-online.target
+
+[Service]
+Type=simple
+User=clickhouse
+Group=clickhouse
+Restart=always
+RestartSec=30
+RuntimeDirectory=clickhouse-server
+StateDirectory=clickhouse
+LogsDirectory=clickhouse-server
+ExecStart=/usr/bin/clickhouse-server --config=/etc/clickhouse-server/config.xml --pid-file=/run/clickhouse-server/clickhouse-server.pid
+LimitNOFILE=262144
+CapabilityBoundingSet=CAP_NET_ADMIN CAP_IPC_LOCK CAP_SYS_NICE
+
+[Install]
+WantedBy=multi-user.target
diff --git a/clickhouse.sysusers b/clickhouse.sysusers
new file mode 100644
index 000000000000..5123caabc259
--- /dev/null
+++ b/clickhouse.sysusers
@@ -0,0 +1,2 @@
+u clickhouse - "ClickHouse Server"
+m clickhouse clickhouse