summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikhail f. Shiryaev2019-05-02 09:59:41 +0200
committerMikhail f. Shiryaev2019-05-02 09:59:41 +0200
commitcf8e18c57590956527dea4093bf4a91df1aaaff3 (patch)
treee7a71aceed0bbfb9df70e5271af4f6b87b3a83b7
parent9ca42526545d0d70e3bd851aba40299eba96de8a (diff)
downloadaur-cf8e18c57590956527dea4093bf4a91df1aaaff3.tar.gz
Fix clang8 building
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77030fd623ae..ee36541514df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = clickhouse-static
pkgdesc = An open-source column-oriented database management system that allows generating analytical data reports in real time. Static binary
pkgver = 19.5.3.8
- pkgrel = 1
+ pkgrel = 2
url = https://clickhouse.yandex/
install = clickhouse-static.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 880603736fc6..9d2f40b84a03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=clickhouse-static
pkgver=19.5.3.8
-pkgrel=1
+pkgrel=2
pkgdesc='An open-source column-oriented database management system that allows generating analytical data reports in real time. Static binary'
arch=('i686' 'x86_64')
url='https://clickhouse.yandex/'
@@ -77,6 +77,12 @@ prepare() {
local contrib_dst="${contrib,,}"
cp -a "$contrib-"*/. "ClickHouse-$pkgver-stable/contrib/$contrib_dst"
done
+
+ # Work around new clang release
+ cd ClickHouse-$pkgver-stable || exit
+ if [ -d dbms/programs/clang/Compiler-8.0.0 ]; then
+ cp -a dbms/programs/clang/Compiler-7.0.0 dbms/programs/clang/Compiler-8.0.0
+ fi
}
build() {