summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyechou2022-06-28 11:51:05 -0500
committerkyechou2022-06-28 11:51:05 -0500
commitbdffc222cc73a86cde953e5d2a23959cf7963073 (patch)
tree71d53898d1bcc1bfe0e5f68344b77abcd079ddaa
parent3465f6891e140a39dd1c1a83d951c7efe0c82dc7 (diff)
downloadaur-bdffc222cc73a86cde953e5d2a23959cf7963073.tar.gz
Update the patch to fix #493
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--fix-linux_true.patch28
3 files changed, 40 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index edc6e37c1b2b..2b25484a51de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = clickrouter-git
pkgdesc = Fast modular packet processing and analysis
- pkgver = 2.0.1.r951.g593d10826
- pkgrel = 3
+ pkgver = 2.0.1.r952.g260e4f0a6
+ pkgrel = 1
url = https://github.com/kohler/click
arch = x86_64
license = custom
@@ -14,6 +14,8 @@ pkgbase = clickrouter-git
conflicts = click-git
replaces = clickrouter
source = clickrouter-git::git+https://github.com/kohler/click
+ source = fix-linux_true.patch
sha256sums = SKIP
+ sha256sums = 0293dd4c4233684574c175ba831dbe7a039b5bf059a06b2bec86b76a4e3cc083
pkgname = clickrouter-git
diff --git a/PKGBUILD b/PKGBUILD
index 7b4ae0bd1a34..0eddcc608e8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Kuan-Yen Chou <kuanyenchou at gmail dot com>
pkgname=clickrouter-git
-pkgver=2.0.1.r951.g593d10826
-pkgrel=3
+pkgver=2.0.1.r952.g260e4f0a6
+pkgrel=1
pkgdesc='Fast modular packet processing and analysis'
depends=('glibc' 'libpcap')
optdepends=()
@@ -13,8 +13,10 @@ license=('custom')
provides=('clickrouter')
conflicts=('clickrouter' 'click' 'click-git')
replaces=('clickrouter')
-source=("$pkgname"::'git+https://github.com/kohler/click')
-sha256sums=('SKIP')
+source=("$pkgname"::'git+https://github.com/kohler/click'
+ 'fix-linux_true.patch')
+sha256sums=('SKIP'
+ '0293dd4c4233684574c175ba831dbe7a039b5bf059a06b2bec86b76a4e3cc083')
pkgver() {
cd "$srcdir/$pkgname"
@@ -31,7 +33,8 @@ prepare() {
sed -i -e 's/\<gzcat\>/zcat/g' ${FILES}
# https://github.com/kohler/click/issues/493
- sed -i -e '/linux_true/d' include/click/cxxprotect.h
+ # https://github.com/kohler/click/pull/504
+ patch -Np1 -i "$srcdir/fix-linux_true.patch"
}
build() {
diff --git a/fix-linux_true.patch b/fix-linux_true.patch
new file mode 100644
index 000000000000..b16c901fc5cb
--- /dev/null
+++ b/fix-linux_true.patch
@@ -0,0 +1,28 @@
+diff --git a/include/click/cxxprotect.h b/include/click/cxxprotect.h
+index 65662aff7..ba6ab2860 100644
+--- a/include/click/cxxprotect.h
++++ b/include/click/cxxprotect.h
+@@ -9,7 +9,9 @@
+ # define public linux_public
+ # define namespace linux_namespace
+ # define false linux_false
++# ifdef linux_true
+ # define true linux_true
++# endif
+ #endif
+
+ #ifndef CLICK_CXX_PROTECT
+diff --git a/include/clicknet/ip.h b/include/clicknet/ip.h
+index c2be5113b..e7ebd736c 100644
+--- a/include/clicknet/ip.h
++++ b/include/clicknet/ip.h
+@@ -9,9 +9,7 @@ CLICK_CXX_PROTECT
+ # include <linux/in.h>
+ #else
+ # include <sys/types.h>
+-#undef true
+ # include <netinet/in.h>
+-#define true linux_true
+ #endif
+
+ /*