summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarchcrack2021-01-28 01:08:30 -0300
committerarchcrack2021-01-28 01:08:30 -0300
commit0becc83c46b3edc376c57bb28ee8430fe6a6d381 (patch)
tree74008dc45451e410ab91568d00eaf8ac60f8c74c
parentfb0b2b759dfcfce846283385950ae6d4a993dbac (diff)
downloadaur-0becc83c46b3edc376c57bb28ee8430fe6a6d381.tar.gz
Added pkgver function
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 772a88b279c4..ef3360931bb5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = clifm-git
- pkgdesc = The KISS file manager: cli-based, ultra-lightweight, and lightning fast (development version)
+ pkgdesc = The KISS file manager: cli-based, ultra-lightweight, and lightning fast
pkgver = 0.27.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/leo-arch/clifm
arch = any
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index db99beed2834..f4ac0446cf69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=clifm-git
pkgver=0.27.1
-pkgrel=2
-pkgdesc="The KISS file manager: cli-based, ultra-lightweight, and lightning fast (development version)"
+pkgrel=3
+pkgdesc="The KISS file manager: cli-based, ultra-lightweight, and lightning fast"
arch=(any)
url="https://github.com/leo-arch/clifm"
license=(GPL2)
@@ -13,6 +13,11 @@ optdepends=('sshfs: SFTP support' 'cifs-utils: Samba support' 'curlftpfs: FTPFS
source=("git+${url}.git")
sha256sums=('SKIP')
+pkgver() {
+ cd "$srcdir/${pkgname%%-*}"
+ curl -s "https://raw.githubusercontent.com/leo-arch/${pkgname%%-*}/master/${pkgname%%-*}.c" | grep "#define VERSION" | cut -d" " -f3 | sed 's/"//g'
+}
+
build() {
cd "$srcdir/${pkgname%%-*}"
gcc -O3 -march=native -s -fstack-protector-strong -o "${pkgname%%-*}" "${pkgname%%-*}.c" -lreadline -lacl -lcap