summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFederico Di Pierro2018-12-02 10:28:52 +0100
committerFederico Di Pierro2018-12-02 10:28:52 +0100
commit76f5bf2de0d5da337808bb53d454f32dbc78f3ef (patch)
treedcb3ec87fd912505205b15f3d08453696ac2f227
downloadaur-76f5bf2de0d5da337808bb53d454f32dbc78f3ef.tar.gz
Added Clight stable releases to aur.
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD39
-rw-r--r--clight.install7
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..958340353549
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = clight
+ pkgdesc = A C daemon that turns your webcam into a light sensor. It can also change display gamma temperature, dim your screen and set your dpms.
+ pkgver = 3.0
+ pkgrel = 1
+ url = https://github.com/FedeDP/Clight
+ install = clight.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ makedepends = bash-completion
+ depends = systemd>=221
+ depends = popt
+ depends = libconfig
+ depends = gsl
+ depends = clightd>=3.0
+ optdepends = geoclue2: to retrieve user location through geoclue2.
+ optdepends = upower: to save energy by increasing timeouts between captures while on battery and to autocalibrate keyboard backlight.
+ backup = etc/default/clight.conf
+ source = Clight-3.0.tar.gz::https://github.com/FedeDP/Clight/archive/3.0.tar.gz
+ sha256sums = d904e20f90e3166d26a9c8a72b401ee104c06c53660b70bb809ba1eabc32b0d3
+
+pkgname = clight
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc2318102697
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Federico Di Pierro <nierro92@gmail.com>
+
+pkgname=clight
+_gitname=Clight
+pkgver=3.0
+pkgrel=1
+pkgdesc="A C daemon that turns your webcam into a light sensor. It can also change display gamma temperature, dim your screen and set your dpms."
+arch=('i686' 'x86_64')
+url="https://github.com/FedeDP/${_gitname}"
+license=('GPL')
+backup=(etc/default/clight.conf)
+depends=('systemd>=221' 'popt' 'libconfig' 'gsl' 'clightd>=3.0')
+makedepends=('git' 'cmake' 'bash-completion')
+optdepends=('geoclue2: to retrieve user location through geoclue2.'
+ 'upower: to save energy by increasing timeouts between captures while on battery and to autocalibrate keyboard backlight.')
+source=("${_gitname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+install=clight.install
+sha256sums=("d904e20f90e3166d26a9c8a72b401ee104c06c53660b70bb809ba1eabc32b0d3")
+
+prepare() {
+ cd "${srcdir}/${_gitname}-${pkgver}"
+ mkdir -p build
+}
+
+build() {
+ cd "${srcdir}/${_gitname}-${pkgver}/build"
+ cmake \
+ -G "Unix Makefiles" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE="Release" \
+ ..
+ make
+}
+
+package() {
+ cd "${srcdir}/${_gitname}-${pkgver}/build"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/clight.install b/clight.install
new file mode 100644
index 000000000000..e525a677d63e
--- /dev/null
+++ b/clight.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo '--> By default, first matching webcam/als device and backlight interface are used.'
+ echo '--> Therefore, it should work out of the box even without any setup in most cases.'
+ echo '--> For any customization, take a look at settings file placed in /etc/default/clight.conf.'
+ echo '--> If you are not in a XDG compliant DE, remember to add clight to your autostart script.'
+}
+