summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFederico Di Pierro2018-11-24 11:14:51 +0100
committerFederico Di Pierro2018-11-24 11:14:51 +0100
commit0c70b685541f85a292ea0e7b100656ef95008c3b (patch)
tree25b411e93c51a1d191e16d97cf00148975704637
parent199adeded5c88afdfaa860be8ee37d7d78a5fdc1 (diff)
downloadaur-0c70b685541f85a292ea0e7b100656ef95008c3b.tar.gz
Updated. Clight now uses cmake.
-rwxr-xr-x.SRCINFO5
-rw-r--r--PKGBUILD21
2 files changed, 19 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2a038770a03..be9b9e0ec8d7 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = clight-git
pkgdesc = A C daemon that turns your webcam into a light sensor. It can also change display gamma temperature, dim your screen and set your dpms.
- pkgver = r463.cbb3a40
+ pkgver = r484.0edbb8e
pkgrel = 1
url = https://github.com/FedeDP/Clight
install = clight.install
@@ -8,13 +8,14 @@ pkgbase = clight-git
arch = x86_64
license = GPL
makedepends = git
+ makedepends = cmake
depends = systemd>=221
depends = popt
depends = libconfig
depends = gsl
depends = clightd-git
optdepends = geoclue2: to retrieve user location through geoclue2.
- optdepends = upower: to save energy by increasing timeouts between captures while on battery.
+ optdepends = upower: to save energy by increasing timeouts between captures while on battery and to autocalibrate keyboard backlight.
backup = etc/default/clight.conf
source = git://github.com/FedeDP/Clight.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d498aece2629..4030888342b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=clight-git
_gitname=Clight
-pkgver=r463.cbb3a40
+pkgver=r484.0edbb8e
pkgrel=1
pkgdesc="A C daemon that turns your webcam into a light sensor. It can also change display gamma temperature, dim your screen and set your dpms."
arch=('i686' 'x86_64')
@@ -10,9 +10,9 @@ url="https://github.com/FedeDP/${_gitname}"
license=('GPL')
backup=(etc/default/clight.conf)
depends=('systemd>=221' 'popt' 'libconfig' 'gsl' 'clightd-git')
-makedepends=('git')
+makedepends=('git' 'cmake')
optdepends=('geoclue2: to retrieve user location through geoclue2.'
- 'upower: to save energy by increasing timeouts between captures while on battery.')
+ 'upower: to save energy by increasing timeouts between captures while on battery and to autocalibrate keyboard backlight.')
source=("git://github.com/FedeDP/${_gitname}.git")
install=clight.install
sha256sums=("SKIP")
@@ -22,12 +22,23 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "${srcdir}/${_gitname}"
+ mkdir -p build
+}
+
build() {
- cd $srcdir/$_gitname
+ cd "${srcdir}/${_gitname}/build"
+ cmake \
+ -G "Unix Makefiles" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE="Release" \
+ ..
make
}
package() {
- cd $srcdir/$_gitname
+ cd "${srcdir}/${_gitname}/build"
make DESTDIR="$pkgdir" install
}