summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-03-10 11:14:32 -0700
committerMark Wagie2021-03-10 11:14:32 -0700
commit17ac98bfdb91c2eb8340f12f47004b6889d83201 (patch)
tree66993f2d80451ddbe41333db242da09bda79e5eb
parent218743c5186deaa56237af3dcb06763cdfb23780 (diff)
downloadaur-17ac98bfdb91c2eb8340f12f47004b6889d83201.tar.gz
use tags, add aarch64
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD59
3 files changed, 45 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd80b1011613..2e672a68c045 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,28 @@
pkgbase = clight-git
- pkgdesc = A C daemon that turns your webcam into a light sensor. It can also change display gamma temperature, dim your screen and set your dpms. Devel version.
- pkgver = r802.ef958f2
+ pkgdesc = A C daemon that turns your webcam into a light sensor. It can also change display gamma temperature, dim your screen and set your dpms.
+ pkgver = 4.4.r3.g0f27079
pkgrel = 1
url = https://github.com/FedeDP/Clight
install = clight.install
- arch = any
+ arch = i686
+ arch = x86_64
+ arch = aarch64
license = GPL
makedepends = git
makedepends = cmake
makedepends = bash-completion
- depends = systemd-libs
- depends = popt
- depends = libconfig
- depends = gsl
depends = clightd-git
- depends = libmodule>=5.0.0
+ depends = gsl
depends = hicolor-icon-theme
- optdepends = geoclue2: to retrieve user location through geoclue2.
- optdepends = upower: to save energy by managing ac states increasing timeouts while on battery.
+ depends = libconfig
+ depends = popt
+ optdepends = geoclue: to retrieve user location through geoclue.
+ optdepends = upower: to save energy by increasing timeouts between captures while on battery and to autocalibrate keyboard backlight.
optdepends = bash-completion: to add support for bash automatic completion.
provides = clight
conflicts = clight
backup = etc/default/clight.conf
- source = git://github.com/FedeDP/Clight.git
+ source = clight::git+https://github.com/FedeDP/Clight.git
sha256sums = SKIP
pkgname = clight-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..48f14a8347c6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!clight.install
diff --git a/PKGBUILD b/PKGBUILD
index 47473555d9d6..78726638f274 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,40 @@
-# Maintainer: Federico Di Pierro <nierro92@gmail.com>
-
+# Maintainer: Mark Wagie <mark dot wagie at tutantota dot com>
+# Contributor: Federico Di Pierro <nierro92@gmail.com>
pkgname=clight-git
-_gitname=Clight
-pkgver=r802.ef958f2
+pkgver=4.4.r3.g0f27079
pkgrel=1
-pkgdesc="A C daemon that turns your webcam into a light sensor. It can also change display gamma temperature, dim your screen and set your dpms. Devel version."
-arch=('any')
-url="https://github.com/FedeDP/${_gitname}"
+pkgdesc="A C daemon that turns your webcam into a light sensor. It can also change display
+ gamma temperature, dim your screen and set your dpms."
+arch=('i686' 'x86_64' 'aarch64')
+url="https://github.com/FedeDP/Clight"
license=('GPL')
-backup=(etc/default/clight.conf)
-depends=('systemd-libs' 'popt' 'libconfig' 'gsl' 'clightd-git' 'libmodule>=5.0.0' 'hicolor-icon-theme')
+depends=('clightd-git' 'gsl' 'hicolor-icon-theme' 'libconfig' 'popt')
makedepends=('git' 'cmake' 'bash-completion')
-optdepends=('geoclue2: to retrieve user location through geoclue2.'
- 'upower: to save energy by managing ac states increasing timeouts while on battery.'
+optdepends=('geoclue: to retrieve user location through geoclue.'
+ 'upower: to save energy by increasing timeouts between captures while on battery
+ and to autocalibrate keyboard backlight.'
'bash-completion: to add support for bash automatic completion.')
-provides=('clight')
-conflicts=('clight')
-source=("git://github.com/FedeDP/${_gitname}.git")
-install=clight.install
-sha256sums=("SKIP")
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+backup=("etc/default/${pkgname%-git}.conf")
+install="${pkgname%-git}.install"
+source=("${pkgname%-git}::git+https://github.com/FedeDP/Clight.git")
+sha256sums=('SKIP')
pkgver() {
- cd "$_gitname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
-prepare() {
- cd "${srcdir}/${_gitname}"
- mkdir -p build
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${_gitname}/build"
- cmake \
- -G "Unix Makefiles" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_BUILD_TYPE="Release" \
- ..
- make
+ cmake -B build -S "${pkgname%-git}" \
+ -G "Unix Makefiles" \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -Wno-dev
+ make -C build
}
package() {
- cd "${srcdir}/${_gitname}/build"
- make DESTDIR="$pkgdir" install
+ make -C build DESTDIR="$pkgdir" install
}