summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFederico Di Pierro2017-04-16 12:19:27 +0200
committerFederico Di Pierro2017-04-16 12:19:27 +0200
commit6588bc53e38699893fc7385e3844b685c7ec0150 (patch)
tree6aac3a793e7e54f0474ab7770a52cb5d4239b879
downloadaur-6588bc53e38699893fc7385e3844b685c7ec0150.tar.gz
first upload
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
-rw-r--r--clight.install7
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a57a3680186
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = clight-git
+ pkgdesc = A C daemon that turns your webcam into a light sensor. It can also change display gamma temperature.
+ pkgver = r78.daf725b
+ pkgrel = 1
+ url = https://github.com/FedeDP/Clight
+ install = clight.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = systemd
+ depends = libxcb
+ depends = popt
+ depends = libconfig
+ depends = clightd-git
+ optdepends = geoclue2: to retrieve user location through geoclue2.
+ source = git://github.com/FedeDP/Clight.git
+ sha256sums = SKIP
+
+pkgname = clight-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b40cb15b81e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Federico Di Pierro <nierro92@gmail.com>
+
+pkgname=clight-git
+_gitname=Clight
+pkgver=r78.daf725b
+pkgrel=1
+pkgdesc="A C daemon that turns your webcam into a light sensor. It can also change display gamma temperature."
+arch=('i686' 'x86_64')
+url="https://github.com/FedeDP/${_gitname}"
+license=('GPL')
+depends=('systemd' 'libxcb' 'popt' 'libconfig' 'clightd-git')
+makedepends=('git')
+optdepends=('geoclue2: to retrieve user location through geoclue2.')
+source=("git://github.com/FedeDP/${_gitname}.git")
+install=clight.install
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $srcdir/$_gitname
+ make
+}
+
+package() {
+ cd $srcdir/$_gitname
+ make DESTDIR="$pkgdir" install
+}
diff --git a/clight.install b/clight.install
new file mode 100644
index 000000000000..70187f057da6
--- /dev/null
+++ b/clight.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo '--> By default, first matching webcam and backlight interface are used.'
+ echo '--> Therefore, it should work out of the box even without any setup in most cases.'
+ echo '--> Remember to enable the unit file shipped (without sudo): systemctl --now --user enable clight.service'
+ echo '--> For any customization, take a look at settings file placed in /etc/default/clight.conf.'
+}
+