summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFederico Di Pierro2017-05-11 19:48:11 +0200
committerFederico Di Pierro2017-05-11 19:48:11 +0200
commitcc51379fdb409e48032f66d0b1bd7e1211dbb1e9 (patch)
treecaf2e89efdcaa0feaaff335bafcf60945dec6869
parent67d8fca52c2d37c8e425503a2041a8664ca0e43a (diff)
downloadaur-cc51379fdb409e48032f66d0b1bd7e1211dbb1e9.tar.gz
new release. Pkgbuild now properly backups global conf file.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--clight.install2
3 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a57a3680186..d4f8bcfeba03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,6 +14,8 @@ pkgbase = clight-git
depends = libconfig
depends = clightd-git
optdepends = geoclue2: to retrieve user location through geoclue2.
+ optdepends = upower: to save energy by increasing timeouts between captures while on battery.
+ backup = etc/default/clight.conf
source = git://github.com/FedeDP/Clight.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b40cb15b81e0..14288d142566 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,9 +8,11 @@ pkgdesc="A C daemon that turns your webcam into a light sensor. It can also chan
arch=('i686' 'x86_64')
url="https://github.com/FedeDP/${_gitname}"
license=('GPL')
+backup=(etc/default/clight.conf)
depends=('systemd' 'libxcb' 'popt' 'libconfig' 'clightd-git')
makedepends=('git')
-optdepends=('geoclue2: to retrieve user location through geoclue2.')
+optdepends=('geoclue2: to retrieve user location through geoclue2.'
+ 'upower: to save energy by increasing timeouts between captures while on battery.')
source=("git://github.com/FedeDP/${_gitname}.git")
install=clight.install
sha256sums=("SKIP")
diff --git a/clight.install b/clight.install
index 42b8e5a88422..089377c6abc4 100644
--- a/clight.install
+++ b/clight.install
@@ -1,7 +1,7 @@
post_install() {
echo '--> By default, first matching webcam and backlight interface are used.'
echo '--> Therefore, it should work out of the box even without any setup in most cases.'
- echo '--> Remember to add 'systemctl --user start clight.service' to your DE autostart.'
+ echo '--> Clight installs a xdg autostart script. This way, clight will be started together with your DE.'
echo '--> For any customization, take a look at settings file placed in /etc/default/clight.conf.'
}