summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-01-22 15:57:18 -0700
committerMark Wagie2022-01-22 15:57:18 -0700
commit97eebd22f564977a71be3fb6c81f9c4bb1620756 (patch)
treec47a7aa0b71ba3ce65d896507092fab7fb4d6f4c
parent8466bda83ce6e975a4e290f2c661c83bc4cfe88f (diff)
downloadaur-97eebd22f564977a71be3fb6c81f9c4bb1620756.tar.gz
build improvements, add ARM64
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce98102aa09b..1b6bf22d9537 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = clight-gui-git
pkgdesc = Qt GUI for Clight
pkgver = r90.f601899
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/nullobsi/clight-gui
arch = x86_64
+ arch = aarch64
license = GPL3
makedepends = git
makedepends = cmake
diff --git a/PKGBUILD b/PKGBUILD
index 647a588d56ae..f55675da8cdc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=clight-gui-git
pkgver=r90.f601899
-pkgrel=1
+pkgrel=2
pkgdesc="Qt GUI for Clight"
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://github.com/nullobsi/clight-gui"
license=('GPL3')
depends=('clight' 'qt5-charts')
@@ -27,11 +27,11 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DGENERATE_TRANSLATIONS=ON \
-Wno-dev
- make -C build
+ cmake --build build
}
package() {
- make -C build DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
install -Dm644 "${pkgname%-git}.desktop" -t "$pkgdir/usr/share/applications"
}