summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-01-22 15:51:52 -0700
committerMark Wagie2022-01-22 15:51:52 -0700
commit66d6d211737af66576b0f9be4a054fe0695049a0 (patch)
tree81bd4bc167370119b50884491ca15df245037986
parent7150d7788a42171df32d17fda2b6037c97863262 (diff)
downloadaur-66d6d211737af66576b0f9be4a054fe0695049a0.tar.gz
various fixes and improvements
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49697227cdf2..42d9f4837509 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = clightd
pkgdesc = Bus interface to change screen brightness and capture frames from webcam.
pkgver = 5.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/FedeDP/Clightd
- arch = i686
arch = x86_64
arch = aarch64
license = GPL
makedepends = git
makedepends = cmake
- depends = systemd-libs>=237
+ depends = systemd-libs
depends = linux-api-headers
depends = libx11
depends = libxrandr
depends = libxext
depends = polkit
- depends = ddcutil>=0.9.5
- depends = libmodule>=5.0.0
+ depends = ddcutil
+ depends = libmodule
depends = libjpeg-turbo
depends = libusb
depends = libdrm
diff --git a/PKGBUILD b/PKGBUILD
index fda9d2cbadbf..c08ecab15097 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# Contributor: Federico Di Pierro <nierro92@gmail.com>
pkgname=clightd
pkgver=5.5
-pkgrel=1
+pkgrel=2
pkgdesc="Bus interface to change screen brightness and capture frames from webcam."
-arch=('i686' 'x86_64' 'aarch64')
+arch=('x86_64' 'aarch64')
url="https://github.com/FedeDP/Clightd"
license=('GPL')
-depends=('systemd-libs>=237' 'linux-api-headers' 'libx11' 'libxrandr' 'libxext' 'polkit'
- 'ddcutil>=0.9.5' 'libmodule>=5.0.0' 'libjpeg-turbo' 'libusb' 'libdrm' 'wayland')
+depends=('systemd-libs' 'linux-api-headers' 'libx11' 'libxrandr' 'libxext' 'polkit'
+ 'ddcutil' 'libmodule' 'libjpeg-turbo' 'libusb' 'libdrm' 'wayland')
makedepends=('git' 'cmake')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('a2153db7a4ed49f8aaab10b4e72c1aba8cb46c773652017a9eb6fe12ad7496f3')
@@ -25,13 +25,9 @@ build() {
-DENABLE_SCREEN=1 \
-DENABLE_YOCTOLIGHT=1 \
-Wno-dev
- make -C build
+ cmake --build build
}
package() {
- make -C build DESTDIR="$pkgdir" install
-
- install -d "$pkgdir/usr/lib/systemd/system"
- mv "$pkgdir/etc/systemd/system/$pkgname.service" "$pkgdir/usr/lib/systemd/system"
- rm -rf "$pkgdir/etc/systemd"
+ DESTDIR="$pkgdir" cmake --install build
}