summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Ker-Seymer2016-11-29 14:15:05 -0500
committerIan Ker-Seymer2016-11-29 14:15:05 -0500
commit61be6ebc026fb4c9f5a818399e0d68f99d080edc (patch)
tree31fce47383f33bfda35bd92d57d2010f187d28e1
parente80c2d2d50421be7bd59d1f555591007e621ab93 (diff)
downloadaur-61be6ebc026fb4c9f5a818399e0d68f99d080edc.tar.gz
Include more optdepends and add install message
-rw-r--r--PKGBUILD7
-rw-r--r--climate.install10
2 files changed, 14 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6269f2c67bd1..d77b6679822b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ license=('GPLv3')
optdepends=('unzip: extracting zip files'
'wget: retrieving files'
'curl: making http requests'
- 'dig: dns support'
+ 'dnsutils: provides dig command'
'git: git support'
'rar: extacting rar files'
'python: running python scripts'
@@ -18,7 +18,10 @@ optdepends=('unzip: extracting zip files'
'node: running node scripts'
'fdupes: de-deplicating files'
'sshfs: ssh filesystem support'
- '7z: extracting 7z files')
+ 'lm_sensors: read cpu temperatures, voltage, fans'
+ 'speedtest-cli: check networking speed'
+ 'gawk: gawk suport'
+ 'p7zip: extracting 7z files')
install="${pkgname}.install"
source=("${url}/archive/v${pkgver}.tar.gz")
sha256sums=('781f42f4d59374e90f9c3efba271209d8b5e985279696bdd93bcd2f826f0177e')
diff --git a/climate.install b/climate.install
index 41983d360137..bab6dcd6e620 100644
--- a/climate.install
+++ b/climate.install
@@ -1,6 +1,14 @@
## arg 1: the new package version
post_install() {
- true;
+ echo "
+In order to use certain commands, you may want to install these node/npm packages:
+
+ $ npm install -g http-server is-up-cli is-online-cli
+
+And these python/pip packages:
+
+ $ pip install httpstat
+"
}
## arg 1: the old package version