summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarchibald8692020-10-21 23:04:34 +0200
committerarchibald8692020-10-21 23:04:34 +0200
commite0bd010cdcd4aab4cedc13b409803d34d4de9bb8 (patch)
tree6bd4a151b91d5d7f0a051f1e24d3f9a45844f829
parent9c8ff269a3d91093fce2c85c7bc3cd971c92c073 (diff)
downloadaur-e0bd010cdcd4aab4cedc13b409803d34d4de9bb8.tar.gz
Add python2 as make dependency and fix compile error
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1efab9d0e0e..c8d55d44f664 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = cling
pkgdesc = Interactive C++ interpreter, built on the top of LLVM and Clang libraries
pkgver = 0.7
- pkgrel = 2
+ pkgrel = 3
url = https://root.cern.ch/cling
arch = i686
arch = x86_64
license = custom:Cling Release License
makedepends = git
makedepends = cmake
+ makedepends = python2
depends = libxml2
optdepends = python2: support for scan-view and Jupyter
optdepends = perl: support for scan-build, ccc-analyzer and c++-analyzer
diff --git a/PKGBUILD b/PKGBUILD
index 9a61e89cc2a9..744667773692 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=cling
pkgver=0.7
-pkgrel=2
+pkgrel=3
pkgdesc="Interactive C++ interpreter, built on the top of LLVM and Clang libraries"
arch=("i686" "x86_64")
url="https://root.cern.ch/cling"
@@ -10,7 +10,7 @@ license=("custom:Cling Release License")
provides=("cling")
conflicts=("cling")
depends=("libxml2")
-makedepends=("git" "cmake")
+makedepends=("git" "cmake" "python2")
optdepends=(
"python2: support for scan-view and Jupyter"
"perl: support for scan-build, ccc-analyzer and c++-analyzer"
@@ -35,6 +35,10 @@ prepare() {
if [ ! -h "$srcdir/llvm/tools/cling" ]; then
ln -s "$srcdir/cling" "$srcdir/llvm/tools/cling"
fi
+
+ # fix compile error "‘EST_ComputedNoexcept’ was not declared in this scope"
+ # see https://github.com/root-project/cling/commit/4203690c46e438f6e43f1aaf8cb41b8b582c6002
+ sed -i 's@if (FT->getExceptionSpecType() == EST_ComputedNoexcept) {@if (isComputedNoexcept(FT->getExceptionSpecType())) {@' "$srcdir/cling/lib/Interpreter/ForwardDeclPrinter.cpp"
}
build() {