summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo60462021-04-10 18:09:49 -0300
committerGustavo60462021-04-10 18:09:49 -0300
commitbfad8a55639a8869717a2397767b07d142733fb8 (patch)
tree5d3dd95f1ca075a33bff68ddb7d87eb1206a4ee5
parent2dd33ec7414a149b1bded974c254285f5cc47093 (diff)
downloadaur-bfad8a55639a8869717a2397767b07d142733fb8.tar.gz
Update cling-bin to 2020.11.05
This includes a convenient .gitignore that prevents accidental upload of unrelated files. Sanitization of the PKGBUILD itself is still due.
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD16
3 files changed, 17 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed84692709d0..ec0ca640f110 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = cling-bin
pkgdesc = The cling C++ interpreter
- pkgver = 20200908
+ pkgver = 2020.11.05
pkgrel = 1
url = https://root.cern.ch/cling
arch = x86_64
license = Cling Release License
depends = ncurses5-compat-libs
- source = https://root.cern/download/cling/cling_2020-09-08_ROOT-ubuntu2004.tar.bz2
- sha256sums = 2c75766f120c907fe96339cb0ce9f6ef6c60aa4d831d450de50d64c6384769a1
+ source = https://root.cern/download/cling/cling_2020-11-05_ROOT-ubuntu2004.tar.bz2
+ sha256sums = 73eb884f866e3d1511c647bc07ba215ab2af5cf2e3a8c9c93e39be9c4bb2eb4e
pkgname = cling-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index d141263a4119..71d1c77a3744 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,12 @@
+#!/bin/bash
+
+# Maintainer: Gustavo Ramos Rehermann <rehermann6046@gmail.com>
+# Contributor: Hao Zhang <hzhangxyz@outlook.com>
+
pkgname=cling-bin
_pkgname=cling
-pkgver=20200908
+pkgver='2020.11.05'
+file_name="cling_$(tr '.' '-'<<<$pkgver)_ROOT-ubuntu2004.tar.bz2"
pkgrel=1
pkgdesc="The cling C++ interpreter"
arch=(x86_64)
@@ -8,17 +14,15 @@ url="https://root.cern.ch/cling"
license=('Cling Release License')
depends=('ncurses5-compat-libs')
-file_name='cling_2020-09-08_ROOT-ubuntu2004'
-
source=(
- "https://root.cern/download/cling/$file_name.tar.bz2"
+ "https://root.cern/download/cling/$file_name"
)
sha256sums=(
- '2c75766f120c907fe96339cb0ce9f6ef6c60aa4d831d450de50d64c6384769a1'
+ '73eb884f866e3d1511c647bc07ba215ab2af5cf2e3a8c9c93e39be9c4bb2eb4e'
)
prepare() {
- tar xvf $file_name.tar.bz2
+ tar xvf "$file_name"
}
package() {