summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Reiser2023-10-02 18:49:26 +0200
committerSimon Reiser2023-10-02 18:49:26 +0200
commit9d59538f0df66ce4cdf6707d3ffe24efc3de980c (patch)
tree0d7374fe0bde4aa51bfce8b853147118955c668a
parent0ca44945c885a48558d922c1a8e7fab0b8738a95 (diff)
downloadaur-cling-git.tar.gz
Fix build
contributor patch can be found here: https://aur.archlinux.org/packages/cling-git#comment-922039
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD34
2 files changed, 20 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 067c7e13b823..a8c04c8e6b4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cling-git
pkgdesc = Interactive C++ interpreter built on the top of LLVM and Clang libraries.
- pkgver = r4811.19a2c1b7
+ pkgver = r5123.45318c5a
pkgrel = 1
url = https://root.cern.ch/cling
arch = i686
@@ -11,10 +11,10 @@ pkgbase = cling-git
makedepends = git
makedepends = python
makedepends = jupyter-notebook
- source = llvm::git+http://root.cern.ch/git/llvm.git#branch=cling-patches
- source = clang::git+http://root.cern.ch/git/clang.git#branch=cling-patches
- source = cling::git+http://root.cern.ch/git/cling.git#branch=master
- sha256sums = SKIP
+ makedepends = ninja
+ options = !lto
+ source = cling-llvm::git+https://github.com/root-project/llvm-project.git#branch=cling-llvm13
+ source = cling::git+https://github.com/root-project/cling.git#branch=master
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ed3dc5c37d42..99b3fe611190 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,21 @@
# Original Maintainer: Eduardo Sánchez Muñoz
pkgname=(cling-git cling-jupyter-git)
-pkgver=r4811.19a2c1b7
+pkgver=r5123.45318c5a
pkgrel=1
pkgdesc="Interactive C++ interpreter built on the top of LLVM and Clang libraries."
arch=('i686' 'x86_64')
url="https://root.cern.ch/cling"
license=('custom:Cling Release License')
-makedepends=('cmake' 'libffi' 'git' 'python' 'jupyter-notebook')
+makedepends=('cmake' 'libffi' 'git' 'python' 'jupyter-notebook' 'ninja')
+options=('!lto') # getting huge RAM usage with LTO (and extra/llvm disables LTO as well)
source=(
- "llvm::git+http://root.cern.ch/git/llvm.git#branch=cling-patches"
- "clang::git+http://root.cern.ch/git/clang.git#branch=cling-patches"
- "cling::git+http://root.cern.ch/git/cling.git#branch=master"
+ "cling-llvm::git+https://github.com/root-project/llvm-project.git#branch=cling-llvm13"
+ "cling::git+https://github.com/root-project/cling.git#branch=master"
)
sha256sums=(
'SKIP'
'SKIP'
- 'SKIP'
)
pkgver() {
@@ -26,20 +25,21 @@ pkgver() {
}
prepare() {
- if [ ! -h "$srcdir/llvm/tools/clang" ]; then
- ln -s "$srcdir/clang" "$srcdir/llvm/tools/clang"
+ if [ ! -h "$srcdir/cling-llvm/llvm/tools/clang" ]; then
+ ln -s "../../clang" "$srcdir/cling-llvm/llvm/tools/clang"
fi
-
- if [ ! -h "$srcdir/llvm/tools/cling" ]; then
- ln -s "$srcdir/cling" "$srcdir/llvm/tools/cling"
+ if [ ! -h "$srcdir/cling-llvm/llvm/tools/cling" ]; then
+ ln -s "$srcdir/cling" "$srcdir/cling-llvm/llvm/tools/cling"
fi
}
build() {
mkdir -p "$srcdir/cling-build"
- cd "$srcdir/cling-build"
cmake \
+ -S "$srcdir/cling-llvm/llvm" \
+ -B "$srcdir/cling-build" \
+ -G Ninja \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="/opt/cling" \
-DLLVM_TARGETS_TO_BUILD="host;NVPTX" \
@@ -50,23 +50,19 @@ build() {
-DLLVM_ENABLE_SPHINX=OFF \
-DLLVM_ENABLE_DOXYGEN=OFF \
-DFFI_INCLUDE_DIR=$(pkg-config --cflags-only-I libffi | cut -c3-) \
- "$srcdir/llvm"
- make -C tools/clang
- make -C tools/cling
+ ninja -C "$srcdir/cling-build" #clang cling
}
package_cling-git() {
depends=('libffi')
- cd "$srcdir/cling-build"
- make -C tools/clang DESTDIR="$pkgdir" install
- make -C tools/cling DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C "$srcdir/cling-build" install
install -d "$pkgdir/usr/bin"
ln -s "/opt/cling/bin/cling" "$pkgdir/usr/bin/cling"
- install -Dm644 "$srcdir/llvm/tools/cling/LICENSE.TXT" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir/cling/LICENSE.TXT" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
package_cling-jupyter-git() {