summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Reiser2022-04-23 09:36:32 +0200
committerSimon Reiser2022-04-23 09:36:32 +0200
commit0ca44945c885a48558d922c1a8e7fab0b8738a95 (patch)
tree8c181d67aae91afe2ec1e56a7fe20a4a3c292a5c
parent5f923f237119f7c68fa33fd1d178dd9c74024bb7 (diff)
downloadaur-0ca44945c885a48558d922c1a8e7fab0b8738a95.tar.gz
Replace jupyter dependency with jupyter-notebook
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01a70c432118..067c7e13b823 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cling-git
pkgdesc = Interactive C++ interpreter built on the top of LLVM and Clang libraries.
- pkgver = r4767.517d7e4b
+ pkgver = r4811.19a2c1b7
pkgrel = 1
url = https://root.cern.ch/cling
arch = i686
@@ -10,7 +10,7 @@ pkgbase = cling-git
makedepends = libffi
makedepends = git
makedepends = python
- makedepends = jupyter
+ makedepends = jupyter-notebook
source = llvm::git+http://root.cern.ch/git/llvm.git#branch=cling-patches
source = clang::git+http://root.cern.ch/git/clang.git#branch=cling-patches
source = cling::git+http://root.cern.ch/git/cling.git#branch=master
@@ -23,4 +23,4 @@ pkgname = cling-git
pkgname = cling-jupyter-git
depends = cling-git
- depends = jupyter
+ depends = jupyter-notebook
diff --git a/PKGBUILD b/PKGBUILD
index 5c640620e4d6..ed3dc5c37d42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
-# Maintainer: Eduardo Sánchez Muñoz
+# Maintainer: Simon Reiser <me AT sfxr DOT de>
+# Original Maintainer: Eduardo Sánchez Muñoz
pkgname=(cling-git cling-jupyter-git)
-pkgver=r4767.517d7e4b
+pkgver=r4811.19a2c1b7
pkgrel=1
pkgdesc="Interactive C++ interpreter built on the top of LLVM and Clang libraries."
arch=('i686' 'x86_64')
url="https://root.cern.ch/cling"
license=('custom:Cling Release License')
-makedepends=('cmake' 'libffi' 'git' 'python' 'jupyter')
+makedepends=('cmake' 'libffi' 'git' 'python' 'jupyter-notebook')
source=(
"llvm::git+http://root.cern.ch/git/llvm.git#branch=cling-patches"
"clang::git+http://root.cern.ch/git/clang.git#branch=cling-patches"
@@ -69,7 +70,7 @@ package_cling-git() {
}
package_cling-jupyter-git() {
- depends=('cling-git' 'jupyter')
+ depends=('cling-git' 'jupyter-notebook')
cd "$srcdir/cling/tools/Jupyter/kernel"
python3 setup.py install --prefix=/usr --root="$pkgdir"