summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Sánchez Muñoz2021-02-01 20:44:40 +0100
committerEduardo Sánchez Muñoz2021-02-01 20:44:40 +0100
commitb8063f79af5490c7b15f103d315eb848bebe666b (patch)
treee4bb17379f894bbac8ebcc08b7ac565290610a20
parent6b0b781a1c0ddae40e76f68aa3dd9e99e3bc6523 (diff)
downloadaur-b8063f79af5490c7b15f103d315eb848bebe666b.tar.gz
remove python2 dependency
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD18
3 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be4be684028a..bbf9f0a0835e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cling-git
pkgdesc = Interactive C++ interpreter built on the top of LLVM and Clang libraries.
- pkgver = r4443.9470e538
+ pkgver = r4585.21249652
pkgrel = 1
url = https://root.cern.ch/cling
arch = i686
@@ -10,7 +10,6 @@ pkgbase = cling-git
makedepends = libffi
makedepends = git
makedepends = python
- makedepends = python2
makedepends = jupyter
source = llvm::git+http://root.cern.ch/git/llvm.git#branch=cling-patches
source = clang::git+http://root.cern.ch/git/clang.git#branch=cling-patches
diff --git a/.gitignore b/.gitignore
index da9f2ba3dc65..dd6d31c55b2f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-/*.pkg.tar.xz
+/*.pkg.tar.zst
/llvm
/clang
/cling
diff --git a/PKGBUILD b/PKGBUILD
index 84a9a4b22a57..0261f6795f5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Eduardo Sánchez Muñoz
pkgname=(cling-git cling-jupyter-git)
-pkgver=r4443.9470e538
+pkgver=r4585.21249652
pkgrel=1
pkgdesc="Interactive C++ interpreter built on the top of LLVM and Clang libraries."
arch=('i686' 'x86_64')
url="https://root.cern.ch/cling"
license=('custom:Cling Release License')
-makedepends=('cmake' 'libffi' 'git' 'python' 'python2' 'jupyter')
+makedepends=('cmake' 'libffi' 'git' 'python' 'jupyter')
source=(
"llvm::git+http://root.cern.ch/git/llvm.git#branch=cling-patches"
"clang::git+http://root.cern.ch/git/clang.git#branch=cling-patches"
@@ -28,7 +28,7 @@ prepare() {
if [ ! -h "$srcdir/llvm/tools/clang" ]; then
ln -s "$srcdir/clang" "$srcdir/llvm/tools/clang"
fi
-
+
if [ ! -h "$srcdir/llvm/tools/cling" ]; then
ln -s "$srcdir/cling" "$srcdir/llvm/tools/cling"
fi
@@ -37,7 +37,7 @@ prepare() {
build() {
mkdir -p "$srcdir/cling-build"
cd "$srcdir/cling-build"
-
+
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="/opt/cling" \
@@ -50,27 +50,27 @@ build() {
-DLLVM_ENABLE_DOXYGEN=OFF \
-DFFI_INCLUDE_DIR=$(pkg-config --cflags-only-I libffi | cut -c3-) \
"$srcdir/llvm"
-
+
make -C tools/clang
make -C tools/cling
}
package_cling-git() {
depends=('libffi')
-
+
cd "$srcdir/cling-build"
make -C tools/clang DESTDIR="$pkgdir" install
make -C tools/cling DESTDIR="$pkgdir" install
-
+
install -d "$pkgdir/usr/bin"
ln -s "/opt/cling/bin/cling" "$pkgdir/usr/bin/cling"
-
+
install -Dm644 "$srcdir/llvm/tools/cling/LICENSE.TXT" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
package_cling-jupyter-git() {
depends=('cling-git' 'jupyter')
-
+
cd "$srcdir/cling/tools/Jupyter/kernel"
python3 setup.py install --prefix=/usr --root="$pkgdir"
jupyter-kernelspec install --prefix="$pkgdir/usr" .