summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Sánchez Muñoz2015-09-26 13:17:08 +0200
committerEduardo Sánchez Muñoz2015-09-26 13:18:05 +0200
commitd6314fcbf2058644a78a69e8178f844be81975dc (patch)
tree919a515b46a94e52b2bf6152922f83f0aa51c6b1
parent53ff0509255db3248b2aaab2ce5d21f3587d1d8e (diff)
downloadaur-d6314fcbf2058644a78a69e8178f844be81975dc.tar.gz
Update to r2663.040bad9
Use CMake and reduce built package size.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD33
2 files changed, 18 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed75dcd3f492..f046fc6b231b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = cling-git
pkgdesc = Interactive C++ interpreter built on the top of LLVM and Clang libraries.
- pkgver = r2631.4b08f20
+ pkgver = r2663.040bad9
pkgrel = 1
url = https://root.cern.ch/drupal/content/cling
arch = i686
arch = x86_64
license = custom:Cling Release License
+ makedepends = cmake
makedepends = libffi
makedepends = clang
makedepends = git
makedepends = python2
- makedepends = make
depends = libffi
source = llvm::git+http://root.cern.ch/git/llvm.git#branch=cling-patches
source = clang::git+http://root.cern.ch/git/clang.git#branch=cling-patches
diff --git a/PKGBUILD b/PKGBUILD
index 35c2b78a82f5..a765f0878a1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Eduardo Sánchez Muñoz
pkgname=cling-git
-pkgver=r2631.4b08f20
+pkgver=r2663.040bad9
pkgrel=1
pkgdesc="Interactive C++ interpreter built on the top of LLVM and Clang libraries."
arch=('i686' 'x86_64')
url="https://root.cern.ch/drupal/content/cling"
license=('custom:Cling Release License')
depends=('libffi')
-makedepends=('libffi' 'clang' 'git' 'python2' 'make')
+makedepends=('cmake' 'libffi' 'clang' 'git' 'python2')
options=()
conflicts=()
provides=()
@@ -35,32 +35,31 @@ prepare() {
build() {
cd "$srcdir"
- rm -rf "$srcdir/cling-build"
mkdir -p "$srcdir/cling-build"
cd "$srcdir/cling-build"
- CPPFLAGS+=" $(pkg-config --cflags libffi)"
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/opt/cling" \
+ -DLLVM_BUILD_LLVM_DYLIB=OFF \
+ -DLLVM_ENABLE_RTTI=ON \
+ -DLLVM_ENABLE_FFI=ON \
+ -DLLVM_BUILD_DOCS=OFF \
+ -DLLVM_ENABLE_SPHINX=OFF \
+ -DLLVM_ENABLE_DOXYGEN=OFF \
+ -DFFI_INCLUDE_DIR=$(pkg-config --cflags-only-I libffi | cut -c3-) \
+ "$srcdir/llvm"
- "$srcdir/llvm/configure" \
- --prefix="/opt/cling" \
- --sysconfdir=/etc \
- --enable-cxx11 \
- --enable-libffi \
- --with-python=python2 \
- --enable-targets=host \
- --enable-bindings=none \
- --enable-optimized \
- --disable-expensive-checks \
- --disable-debug-runtime \
- --disable-assertions
make
}
package() {
cd "$srcdir/cling-build"
- make DESTDIR="$pkgdir" install
+ make -C tools/clang DESTDIR="$pkgdir" install
+ make -C tools/cling DESTDIR="$pkgdir" install
install -d "$pkgdir/usr/bin"
ln -s "/opt/cling/bin/cling" "$pkgdir/usr/bin/cling"
+
install -Dm644 "$srcdir/llvm/tools/cling/LICENSE.TXT" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}