summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Sánchez Muñoz2016-11-25 11:19:17 +0100
committerEduardo Sánchez Muñoz2016-11-25 11:19:17 +0100
commitfb3e98ac07fcb7308ce39ff696abb2d730bbeee4 (patch)
treea79c286990236c6a6d3cc2ea320b840ccaaf5f0b
parent11bfa5b0fab28c7a9d1dac88a2cb3148047b589b (diff)
downloadaur-fb3e98ac07fcb7308ce39ff696abb2d730bbeee4.tar.gz
Remove the jupyter path patch.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--cling-jupyter-path.diff22
3 files changed, 4 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95a0b61fd11b..2902318bb70d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Sep 12 09:33:18 UTC 2016
+# Fri Nov 25 10:17:44 UTC 2016
pkgbase = cling-git
pkgdesc = Interactive C++ interpreter built on the top of LLVM and Clang libraries.
- pkgver = r3344.bb14201
+ pkgver = r3516.9157aad
pkgrel = 1
url = https://root.cern.ch/cling
arch = i686
@@ -17,11 +17,9 @@ pkgbase = cling-git
source = llvm::git+http://root.cern.ch/git/llvm.git#branch=cling-patches
source = clang::git+http://root.cern.ch/git/clang.git#branch=cling-patches
source = cling::git+http://root.cern.ch/git/cling.git#branch=master
- source = cling-jupyter-path.diff
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 9569ca1bfc0b675c86f51904de96ed47254490f7f9ba6bc8540210f9269898a9
pkgname = cling-git
depends = libffi
diff --git a/PKGBUILD b/PKGBUILD
index fa2c4871fd19..d62322b2930a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Eduardo Sánchez Muñoz
pkgname=(cling-git cling-jupyter-git)
-pkgver=r3344.bb14201
+pkgver=r3516.9157aad
pkgrel=1
pkgdesc="Interactive C++ interpreter built on the top of LLVM and Clang libraries."
arch=('i686' 'x86_64')
@@ -12,13 +12,11 @@ source=(
"llvm::git+http://root.cern.ch/git/llvm.git#branch=cling-patches"
"clang::git+http://root.cern.ch/git/clang.git#branch=cling-patches"
"cling::git+http://root.cern.ch/git/cling.git#branch=master"
- "cling-jupyter-path.diff"
)
sha256sums=(
'SKIP'
'SKIP'
'SKIP'
- '9569ca1bfc0b675c86f51904de96ed47254490f7f9ba6bc8540210f9269898a9'
)
pkgver() {
@@ -34,9 +32,6 @@ prepare() {
if [ ! -h "$srcdir/llvm/tools/cling" ]; then
ln -s "$srcdir/cling" "$srcdir/llvm/tools/cling"
fi
-
- cd "$srcdir/cling"
- git apply "$srcdir/cling-jupyter-path.diff"
}
build() {
@@ -78,5 +73,5 @@ package_cling-jupyter-git() {
cd "$srcdir/cling/tools/Jupyter/kernel"
python3 setup.py install --prefix=/usr --root="$pkgdir"
- jupyter-kernelspec install --prefix="$pkgdir/usr" cling
+ jupyter-kernelspec install --prefix="$pkgdir/usr" .
}
diff --git a/cling-jupyter-path.diff b/cling-jupyter-path.diff
deleted file mode 100644
index 66a67bd0c2b3..000000000000
--- a/cling-jupyter-path.diff
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --git a/tools/Jupyter/kernel/clingkernel.py b/tools/Jupyter/kernel/clingkernel.py
-index befb193..a1c796c 100644
---- a/tools/Jupyter/kernel/clingkernel.py
-+++ b/tools/Jupyter/kernel/clingkernel.py
-@@ -67,11 +67,12 @@ class ClingKernel(Kernel):
-
- def __init__(self, **kwargs):
- super(ClingKernel, self).__init__(**kwargs)
-- try:
-- whichCling = shutil.which('cling')
-- except AttributeError:
-- from distutils.spawn import find_executable
-- whichCling = find_executable('cling')
-+ #try:
-+ # whichCling = shutil.which('cling')
-+ #except AttributeError:
-+ # from distutils.spawn import find_executable
-+ # whichCling = find_executable('cling')
-+ whichCling = "/opt/cling/bin/cling"
- if whichCling:
- clingInstDir = os.path.dirname(os.path.dirname(whichCling))
- llvmResourceDir = clingInstDir