summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Sánchez Muñoz2016-04-11 14:20:56 +0200
committerEduardo Sánchez Muñoz2016-04-11 14:20:56 +0200
commitfe72e3552003917f56db1ec1fb851b451ba8ed6a (patch)
tree1be94d9735925433970ccd7ecae3fba522962c88
parent20c9d2521109f909e65e55eb8a6a94c90b647c03 (diff)
downloadaur-fe72e3552003917f56db1ec1fb851b451ba8ed6a.tar.gz
Update Jupyter kernel patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--cling-jupyter-path.diff16
3 files changed, 17 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7984546f427..c3027446b74d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Feb 17 14:12:25 UTC 2016
+# Mon Apr 11 12:20:28 UTC 2016
pkgbase = cling-git
pkgdesc = Interactive C++ interpreter built on the top of LLVM and Clang libraries.
- pkgver = r2850.a754fcc
+ pkgver = r2889.bb7b609
pkgrel = 1
url = https://root.cern.ch/cling
arch = i686
@@ -21,7 +21,7 @@ pkgbase = cling-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 2d601fe5c75388a0c9e6cdbef6d15f356ea7b9957c9d56525becf247025a7ed2
+ sha256sums = 9569ca1bfc0b675c86f51904de96ed47254490f7f9ba6bc8540210f9269898a9
pkgname = cling-git
depends = libffi
diff --git a/PKGBUILD b/PKGBUILD
index f1a77de92262..aecca0a38e89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Eduardo Sánchez Muñoz
pkgname=(cling-git cling-jupyter-git)
-pkgver=r2850.a754fcc
+pkgver=r2889.bb7b609
pkgrel=1
pkgdesc="Interactive C++ interpreter built on the top of LLVM and Clang libraries."
arch=('i686' 'x86_64')
@@ -15,7 +15,7 @@ source=("llvm::git+http://root.cern.ch/git/llvm.git#branch=cling-patches"
sha256sums=('SKIP'
'SKIP'
'SKIP'
- '2d601fe5c75388a0c9e6cdbef6d15f356ea7b9957c9d56525becf247025a7ed2')
+ '9569ca1bfc0b675c86f51904de96ed47254490f7f9ba6bc8540210f9269898a9')
pkgver() {
cd "$srcdir/cling"
diff --git a/cling-jupyter-path.diff b/cling-jupyter-path.diff
index 6b0e4f5abdb2..66a67bd0c2b3 100644
--- a/cling-jupyter-path.diff
+++ b/cling-jupyter-path.diff
@@ -1,13 +1,21 @@
diff --git a/tools/Jupyter/kernel/clingkernel.py b/tools/Jupyter/kernel/clingkernel.py
-index 9decdda..079b245 100644
+index befb193..a1c796c 100644
--- a/tools/Jupyter/kernel/clingkernel.py
+++ b/tools/Jupyter/kernel/clingkernel.py
-@@ -67,7 +67,8 @@ class ClingKernel(Kernel):
+@@ -67,11 +67,12 @@ class ClingKernel(Kernel):
def __init__(self, **kwargs):
super(ClingKernel, self).__init__(**kwargs)
-- whichCling = shutil.which('cling')
-+ #whichCling = shutil.which('cling')
+- try:
+- whichCling = shutil.which('cling')
+- except AttributeError:
+- from distutils.spawn import find_executable
+- whichCling = find_executable('cling')
++ #try:
++ # whichCling = shutil.which('cling')
++ #except AttributeError:
++ # from distutils.spawn import find_executable
++ # whichCling = find_executable('cling')
+ whichCling = "/opt/cling/bin/cling"
if whichCling:
clingInstDir = os.path.dirname(os.path.dirname(whichCling))