summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarchibald8692019-08-28 13:40:55 +0200
committerarchibald8692019-08-28 13:40:55 +0200
commit9844ff365dbee21432ecb0cd269fe7807d471030 (patch)
treeff5bc718f3d82835ce6cb0c0d84faa3275bb6b31
parenta28e998cc9a18fdd0dddb6d7225565c59429f3f4 (diff)
downloadaur-9844ff365dbee21432ecb0cd269fe7807d471030.tar.gz
Update to version 0.7+dev_20190827
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d3b7e1a633b..dec6086bc505 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = cling-nightly
pkgdesc = Interactive C++ interpreter, built on the top of LLVM and Clang libraries
- pkgver = 0.5.20190615
+ pkgver = 0.7+dev_20190827
pkgrel = 1
url = https://root.cern.ch/cling
arch = i686
arch = x86_64
license = custom:Cling Release License
depends = libxml2
- depends = ncurses
optdepends = python2: support for scan-view and Jupyter
optdepends = perl: support for scan-build, ccc-analyzer and c++-analyzer
provides = cling
conflicts = cling
- source = cling-nightly-0.5.20190615.tar.bz2::https://root.cern.ch/download/cling/cling_2019-06-15_sources.tar.bz2
- sha256sums = 2fe9c2a831c392c22678534f5f34df961399af3766972615cb21b62da113b39d
+ source = cling-nightly-0.7+dev_20190827.tar.bz2::https://root.cern.ch/download/cling/cling_2019-08-27_sources.tar.bz2
+ sha256sums = 5cdc635778fc8257f6677183823adba709b64449f0319ce59879952213a1b5e1
pkgname = cling-nightly
diff --git a/PKGBUILD b/PKGBUILD
index a47bd84d1d3b..886f5356eb24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=cling-nightly
_pkgname=cling
-_build_date=2019-06-15
-pkgver=0.5.${_build_date//-}
+_build_date=2019-08-27
+pkgver=0.7+dev_${_build_date//-}
pkgrel=1
pkgdesc="Interactive C++ interpreter, built on the top of LLVM and Clang libraries"
arch=("i686" "x86_64")
@@ -11,7 +11,7 @@ url="https://root.cern.ch/cling"
license=("custom:Cling Release License")
provides=("cling")
conflicts=("cling")
-depends=(libxml2 ncurses)
+depends=("libxml2")
optdepends=(
"python2: support for scan-view and Jupyter"
"perl: support for scan-build, ccc-analyzer and c++-analyzer"
@@ -20,10 +20,11 @@ source=(
"${pkgname}-${pkgver}.tar.bz2::https://root.cern.ch/download/cling/cling_${_build_date}_sources.tar.bz2"
)
sha256sums=(
- "2fe9c2a831c392c22678534f5f34df961399af3766972615cb21b62da113b39d"
+ "5cdc635778fc8257f6677183823adba709b64449f0319ce59879952213a1b5e1"
)
_num_cores=$(getconf _NPROCESSORS_ONLN)
+
build() {
mkdir -p "$srcdir/build"
cd "$srcdir/build"
@@ -48,5 +49,6 @@ package() {
install -d "$pkgdir/usr/bin"
ln -s "/opt/cling/bin/cling" "$pkgdir/usr/bin/cling"
- install -Dm644 "$srcdir/src/tools/cling/LICENSE.TXT" "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ install -Dm644 "$srcdir/src/tools/cling/LICENSE.TXT" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}