summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarchibald8692019-04-03 11:03:26 +0200
committerarchibald8692019-04-03 11:03:26 +0200
commitac89423b279747d04db822b75c7778c7f6b9ea72 (patch)
tree82796f86e96de9d4c73cbbafb0a3fbd12591c024
parent86131b0108c0c2bd143cd666859fb8a62d28fd71 (diff)
downloadaur-ac89423b279747d04db822b75c7778c7f6b9ea72.tar.gz
Update to version 0.5.20190402
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile10
-rw-r--r--PKGBUILD16
3 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 719a14cc4e83..49a11147c5e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cling-nightly
pkgdesc = Interactive C++ interpreter, built on the top of LLVM and Clang libraries
- pkgver = 0.5.20190301
+ pkgver = 0.5.20190402
pkgrel = 1
url = https://root.cern.ch/cling
arch = i686
@@ -12,8 +12,8 @@ pkgbase = cling-nightly
optdepends = perl: support for scan-build, ccc-analyzer and c++-analyzer
provides = cling
conflicts = cling
- source = cling-nightly-0.5.20190301.tar.bz2::https://root.cern.ch/download/cling/cling_2019-03-01_sources.tar.bz2
- sha256sums = bd79bf54344de385e9a351c9a4df82d557fdb3b7b926eb1ce6449171a096727b
+ source = cling-nightly-0.5.20190402.tar.bz2::https://root.cern.ch/download/cling/cling_2019-04-02_sources.tar.bz2
+ sha256sums = c28edca286a281d0acc491e3d39ebf889a7e13f3619f43b400afb8b6a0a5aa12
pkgname = cling-nightly
diff --git a/Makefile b/Makefile
index 7ed6142f281e..8da8b589145b 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
.DEFAULT_GOAL := .SRCINFO
-.PHONY: all build install clean
+.PHONY: all install check clean
.SRCINFO: PKGBUILD
makepkg --printsrcinfo > .SRCINFO
@@ -8,9 +8,13 @@ all: build install
build: PKGBUILD .SRCINFO
makepkg -f
+ touch build
-install: PKGBUILD build
+install: build
makepkg -i
+check: build
+ namcap *.tar.xz
+
clean:
- rm -rf pkg src *.tar.* *.part
+ rm -rf build pkg src *.tar.* *.part
diff --git a/PKGBUILD b/PKGBUILD
index 81ebc03432f7..c203c4eb6302 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: archibald869 at web dot de
+# Maintainer: archibald869 <archibald869 at web dot de>
pkgname=cling-nightly
_pkgname=cling
-_build_date=2019-03-01
+_build_date=2019-04-02
pkgver=0.5.${_build_date//-}
pkgrel=1
pkgdesc="Interactive C++ interpreter, built on the top of LLVM and Clang libraries"
@@ -20,9 +20,9 @@ source=(
"${pkgname}-${pkgver}.tar.bz2::https://root.cern.ch/download/cling/cling_${_build_date}_sources.tar.bz2"
)
sha256sums=(
- "bd79bf54344de385e9a351c9a4df82d557fdb3b7b926eb1ce6449171a096727b"
+ "c28edca286a281d0acc491e3d39ebf889a7e13f3619f43b400afb8b6a0a5aa12"
)
-_cores=$(getconf _NPROCESSORS_ONLN)
+_num_cores=$(getconf _NPROCESSORS_ONLN)
build() {
mkdir -p "$srcdir/build"
@@ -35,15 +35,15 @@ build() {
-DLLVM_ENABLE_RTTI=ON \
"$srcdir/src"
- make -C tools/clang -j$_cores
- make -C tools/cling -j$_cores
+ make -C tools/clang -j$_num_cores
+ make -C tools/cling -j$_num_cores
}
package() {
cd "$srcdir/build"
- make -C tools/clang -j$_cores DESTDIR="$pkgdir" install
- make -C tools/cling -j$_cores DESTDIR="$pkgdir" install
+ make -C tools/clang -j$_num_cores DESTDIR="$pkgdir" install
+ make -C tools/cling -j$_num_cores DESTDIR="$pkgdir" install
install -d "$pkgdir/usr/bin"
ln -s "/opt/cling/bin/cling" "$pkgdir/usr/bin/cling"