summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarchibald8692019-02-07 17:14:28 +0100
committerarchibald8692019-02-07 17:14:28 +0100
commitc2885a7798eebfa90bbad74ab694393914d6cade (patch)
tree18a08870f80ac148ba9db0dc1914611575b62c4d
downloadaur-c2885a7798eebfa90bbad74ab694393914d6cade.tar.gz
Initial commit (v0.5.20190123)
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD52
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..627478a0fa3c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = cling-nightly
+ pkgdesc = Interactive C++ interpreter, built on the top of LLVM and Clang libraries
+ pkgver = 0.5.20190123
+ pkgrel = 1
+ url = https://root.cern.ch/cling
+ arch = i686
+ arch = x86_64
+ license = custom:Cling Release License
+ depends = libxml2
+ depends = ncurses
+ optdepends = python2: support for scan-view and Jupyter
+ optdepends = perl: support for ccc-analyzer and c++-analyzer
+ provides = cling
+ conflicts = cling
+ source = cling-nightly-0.5.20190123.tar.bz2::https://root.cern.ch/download/cling/cling_2019-01-23_sources.tar.bz2
+ sha256sums = 66ab0509d01affeddf561d4f1c67db6ecfe57e2c4c9d162fe189dc4b3380e504
+
+pkgname = cling-nightly
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fb3099a87912
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg/
+/src/
+*.tar.bz2
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e545cf7cdea1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: archibald869 at web dot de
+
+pkgname=cling-nightly
+_pkgname=cling
+pkgver=0.5.20190123
+pkgrel=1
+pkgdesc="Interactive C++ interpreter, built on the top of LLVM and Clang libraries"
+arch=("i686" "x86_64")
+url="https://root.cern.ch/cling"
+license=("custom:Cling Release License")
+provides=("cling")
+conflicts=("cling")
+depends=(libxml2 ncurses)
+optdepends=(
+ "python2: support for scan-view and Jupyter"
+ "perl: support for ccc-analyzer and c++-analyzer"
+)
+source=(
+ "${pkgname}-${pkgver}.tar.bz2::https://root.cern.ch/download/cling/cling_2019-01-23_sources.tar.bz2"
+)
+sha256sums=(
+ "66ab0509d01affeddf561d4f1c67db6ecfe57e2c4c9d162fe189dc4b3380e504"
+)
+_cores=$(getconf _NPROCESSORS_ONLN)
+
+build() {
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build"
+
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/opt/cling" \
+ -DLLVM_TARGETS_TO_BUILD="host" \
+ -DLLVM_ENABLE_RTTI=ON \
+ "$srcdir/src"
+
+ make -C tools/clang -j$_cores
+ make -C tools/cling -j$_cores
+}
+
+package() {
+ cd "$srcdir/build"
+
+ cores=$(getconf _NPROCESSORS_ONLN)
+ make -C tools/clang -j$_cores DESTDIR="$pkgdir" install
+ make -C tools/cling -j$_cores DESTDIR="$pkgdir" install
+
+ install -d "$pkgdir/usr/bin"
+ ln -s "/opt/cling/bin/cling" "$pkgdir/usr/bin/cling"
+
+ install -Dm644 "$srcdir/src/tools/cling/LICENSE.TXT" "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}