summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarchibald8692019-02-07 10:47:56 +0100
committerarchibald8692019-02-07 10:47:56 +0100
commit4b34fa36c4a6513c4d077a33af89be1f2a77b9cb (patch)
tree146cd65ef5a724f540803c885fe3b8acec268baa
downloadaur-4b34fa36c4a6513c4d077a33af89be1f2a77b9cb.tar.gz
Initial commit (v0.5.20190123)
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD44
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1f459846fd2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = cling-nightly-bin
+ pkgdesc = Interactive C++ interpreter, built on the top of LLVM and Clang libraries
+ pkgver = 0.5.20190123
+ pkgrel = 1
+ url = https://root.cern.ch/cling
+ arch = i686
+ arch = x86_64
+ license = custom:Cling Release License
+ depends = libxml2
+ depends = ncurses
+ optdepends = python2.7: support for scan-view, opt-viewer, Jupyter
+ optdepends = perl: support for ccc-analyzer, c++-analyzer, scan-build
+ provides = cling
+ conflicts = cling
+ source = cling-nightly-bin-0.5.20190123.tar.bz2::https://root.cern.ch/download/cling/cling_2019-01-23_cc7.tar.bz2
+ source = https://raw.githubusercontent.com/root-project/cling/master/LICENSE.TXT
+ sha256sums = d52e3b51bad24157f7513c2a2c06ab2b11b720e9b3bd0d721a66a91dae7ef2ff
+ sha256sums = a9105b805411fddb0c7c829b9fecb85d0d200c9b49aaa0c1a510daa7796b72b4
+
+pkgname = cling-nightly-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fb3099a87912
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg/
+/src/
+*.tar.bz2
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..90556d4a93ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: archibald869 at web dot de
+
+pkgname=cling-nightly-bin
+_pkgname=cling
+pkgver=0.5.20190123
+pkgrel=1
+pkgdesc="Interactive C++ interpreter, built on the top of LLVM and Clang libraries"
+arch=("i686" "x86_64")
+url="https://root.cern.ch/cling"
+license=("custom:Cling Release License")
+provides=("cling")
+conflicts=("cling")
+depends=(libxml2 ncurses)
+optdepends=(
+ 'python2.7: support for scan-view, opt-viewer, Jupyter'
+ 'perl: support for ccc-analyzer, c++-analyzer, scan-build'
+)
+source=(
+ "${pkgname}-${pkgver}.tar.bz2::https://root.cern.ch/download/cling/cling_2019-01-23_cc7.tar.bz2"
+ https://raw.githubusercontent.com/root-project/cling/master/LICENSE.TXT
+)
+sha256sums=(
+ "d52e3b51bad24157f7513c2a2c06ab2b11b720e9b3bd0d721a66a91dae7ef2ff"
+ "a9105b805411fddb0c7c829b9fecb85d0d200c9b49aaa0c1a510daa7796b72b4"
+)
+
+package() {
+ cd "$srcdir"
+
+ # cling requires libtinfo.so.5. libtinfo.so[.6] is shipped with ncurses.
+ # If libtinfo.so.5 is not installed, create a symlink to libtinfo.so.6.
+ if [ ! -f /usr/lib/libtinfo.so.5 ]; then
+ install -d "$pkgdir/usr/lib"
+ ln -s /usr/lib/libtinfo.so.6 "$pkgdir/usr/lib/libtinfo.so.5"
+ fi
+
+ install -d "$pkgdir/opt/$_pkgname"
+ cp -r cling_*/* "$pkgdir/opt/$_pkgname"
+
+ install -d "$pkgdir/usr/bin"
+ ln -sf "/opt/$_pkgname/bin/cling" "$pkgdir/usr/bin/cling"
+
+ install -Dm644 LICENSE.TXT "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}