summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkikadf2019-01-31 16:05:04 +0100
committerkikadf2019-01-31 16:05:04 +0100
commitaa5dbe2259290b4f83f3616deb5120da6ae007d2 (patch)
tree8eeabd692ef65c28e29fcfd50120cbb95065c162
downloadaur-aa5dbe2259290b4f83f3616deb5120da6ae007d2.tar.gz
New package
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
-rw-r--r--clipgrab.desktop13
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0cf983875ade
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = clipgrab-kde
+ pkgdesc = A video downloader and converter for YouTube, Veoh, DailyMotion, MyVideo, ...
+ pkgver = 3.8.0
+ pkgrel = 1
+ url = https://clipgrab.org
+ arch = x86_64
+ license = GPL3
+ makedepends = qt5-tools
+ depends = qt5-webengine
+ optdepends = ffmpeg: for the conversion functionality
+ provides = clipgrab
+ conflicts = clipgrab
+ source = https://download.clipgrab.org/clipgrab-3.8.0.tar.gz
+ source = clipgrab.desktop
+ source = https://gitlab.com/kikadf/clipgrab-qt5/raw/master/clipgrab-3.8.0-kde.patch
+ sha256sums = e67485514e12ed4c4c7a1e70d1f9d51b093677088617ae44c2f68f729d4490d6
+ sha256sums = 840910097d8c129ea12c395c4a33f562591e878e521c98fde8a7b3f9403aa23f
+ sha256sums = 78fc61790876e2156db18c1c9ba2c16494f5c3e1169c3b3b8c53a529b331e8e9
+
+pkgname = clipgrab-kde
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b68c354d214e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: kikadf <kikadf.01@gmail.com>
+
+pkgname=clipgrab-kde
+pkgver=3.8.0
+pkgrel=1
+pkgdesc='A video downloader and converter for YouTube, Veoh, DailyMotion, MyVideo, ...'
+arch=(x86_64)
+url='https://clipgrab.org'
+license=(GPL3)
+depends=(qt5-webengine)
+optdepends=('ffmpeg: for the conversion functionality')
+makedepends=('qt5-tools')
+conflicts=('clipgrab')
+provides=('clipgrab')
+source=(https://download.clipgrab.org/clipgrab-${pkgver}.tar.gz
+ clipgrab.desktop
+ https://gitlab.com/kikadf/clipgrab-qt5/raw/master/clipgrab-${pkgver}-kde.patch)
+sha256sums=('e67485514e12ed4c4c7a1e70d1f9d51b093677088617ae44c2f68f729d4490d6'
+ '840910097d8c129ea12c395c4a33f562591e878e521c98fde8a7b3f9403aa23f'
+ '78fc61790876e2156db18c1c9ba2c16494f5c3e1169c3b3b8c53a529b331e8e9')
+
+prepare() {
+ cd clipgrab-${pkgver}
+ patch -p1 -i ../clipgrab-${pkgver}-kde.patch
+ lrelease clipgrab.pro
+ lupdate clipgrab.pro
+}
+
+build() {
+ cd clipgrab-${pkgver}
+ qmake \
+ QMAKE_CFLAGS_RELEASE="$CPPFLAGS $CFLAGS" \
+ QMAKE_CXXFLAGS_RELEASE="$CPPFLAGS $CXXFLAGS" \
+ QMAKE_LFLAGS_RELEASE="$LDFLAGS" \
+ clipgrab.pro
+ make
+}
+
+package() {
+ cd clipgrab-${pkgver}
+ install -Dm755 clipgrab -t "$pkgdir"/usr/bin/
+ install -Dm644 icon.png "$pkgdir/usr/share/pixmaps/clipgrab.png"
+ install -Dm644 "$srcdir"/clipgrab.desktop -t "$pkgdir"/usr/share/applications/
+}
diff --git a/clipgrab.desktop b/clipgrab.desktop
new file mode 100644
index 000000000000..dad31cfddb2b
--- /dev/null
+++ b/clipgrab.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Type=Application
+Encoding=UTF-8
+Name=ClipGrab
+GenericName=Video Downloader
+GenericName[de]=Video-Downloader
+Comment=Download videos and convert it
+Comment[de]=Videos herunterladen und konvertieren
+Icon=/usr/share/pixmaps/clipgrab.png
+Exec=clipgrab
+TryExec=clipgrab
+Terminal=false
+Categories=Qt;AudioVideo;Audio;Video;