summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis V2021-10-30 10:40:35 -0500
committerLuis V2021-10-30 10:40:35 -0500
commite38e9b602ae70caacad20c5f33ba47062e3eaddb (patch)
tree4804a12dc10f53fb024cfe122a39ca457dfbe9da
downloadaur-e38e9b602ae70caacad20c5f33ba47062e3eaddb.tar.gz
add cliphist
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f374149d16f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cliphist
+ pkgdesc = clipboard history “manager” for wayland
+ pkgver = 0.3.0
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/sentriz/cliphist
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = go
+ depends = wl-clipboard
+ optdepends = xdg-utils
+ conflicts = cliphist-bin
+ source = cliphist-0.3.0.tar.gz::https://github.com/sentriz/cliphist/archive/v0.3.0.tar.gz
+ sha256sums = a0ff01e0d0fc601671d131773fc6f68a3116e631d74b97553dcf68502440e277
+
+pkgname = cliphist
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..477e12c063a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Luis Aleman Vazquez <luisv@tuta.io>
+
+pkgname=cliphist
+pkgver=0.3.0
+pkgrel=1
+epoch=1
+_tag='5a4258fa72c0e34625f949c8114da9ae46c91b6f'
+pkgdesc='clipboard history “manager” for wayland'
+arch=('i686' 'x86_64')
+url="https://github.com/sentriz/$pkgname"
+license=('GPL3')
+depends=('wl-clipboard')
+makedepends=('go')
+optdepends=('xdg-utils')
+conflicts=('cliphist-bin')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('a0ff01e0d0fc601671d131773fc6f68a3116e631d74b97553dcf68502440e277')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ export GOFLAGS="-buildmode=pie -trimpath -modcacherw"
+ go build -o $pkgname
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm0755 -t "$pkgdir"/usr/bin $pkgname
+}
+
+# vim:set ts=2 sw=2 et: