summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernhard Landauer2018-08-09 22:50:31 +0200
committerBernhard Landauer2018-08-09 22:50:31 +0200
commit9a267b3df41b421fa6962c526b1fb3b44cdcd4e1 (patch)
tree3fcb3e7b3fb6f80ff5055bbe6c37697642da9981
parentaa2e282fadaee0ac5a29c0b7f468580fa8946a13 (diff)
downloadaur-9a267b3df41b421fa6962c526b1fb3b44cdcd4e1.tar.gz
push missing changes
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD14
-rw-r--r--fix_version.patch12
3 files changed, 30 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b09f43a4ac6f..34cab48f928a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
# Generated by mksrcinfo v8
-# Thu Aug 9 08:06:35 UTC 2018
+# Thu Aug 9 20:49:52 UTC 2018
pkgbase = clipit
pkgdesc = Lightweight GTK+ clipboard manager (fork of Parcellite)
pkgver = 1.4.4
- pkgrel = 1
- url = https://github.com/CristianHenzel/ClipIt/
+ pkgrel = 3
+ url = https://github.com/CristianHenzel/ClipIt
arch = i686
arch = x86_64
license = GPL3
makedepends = intltool
- depends = gtk2
- depends = libappindicator-gtk2
+ depends = gtk3
+ depends = libappindicator-gtk3
optdepends = xdotool: for automatic paste
- source = https://github.com/CristianHenzel/ClipIt//archive/v1.4.4.tar.gz
+ source = https://github.com/CristianHenzel/ClipIt/archive/v1.4.4.tar.gz
+ source = fix_version.patch
+ source = https://patch-diff.githubusercontent.com/raw/CristianHenzel/ClipIt/pull/90.patch
md5sums = d49b9171c0b81269deafab9d6ecc7610
+ md5sums = 804f2a5bf60b5644087d2f8b7c227a0e
+ md5sums = 46e896a385ff9c8fa65c08d5d9d2e5c6
pkgname = clipit
diff --git a/PKGBUILD b/PKGBUILD
index 75850b2f1886..3a8615bb8f0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,26 @@
pkgname=clipit
_pkgname=ClipIt
pkgver=1.4.4
-pkgrel=2
+pkgrel=3
pkgdesc="Lightweight GTK+ clipboard manager (fork of Parcellite)"
arch=('i686' 'x86_64')
-url="https://github.com/CristianHenzel/ClipIt/"
-_snapshot=d6fab2be79b2fc8319b492a1a834300df64e4db8
+url="https://github.com/CristianHenzel/ClipIt"
+#_snapshot=d6fab2be79b2fc8319b492a1a834300df64e4db8
license=('GPL3')
-depends=('gtk2' 'libappindicator-gtk2')
+depends=('gtk3' 'libappindicator-gtk3')
makedepends=('intltool')
optdepends=('xdotool: for automatic paste')
source=("$url/archive/v$pkgver.tar.gz"
# "${_pkgname}-${_snapshot}.tar.gz::${url}/archive/${_snapshot}.tar.gz"
- https://patch-diff.githubusercontent.com/raw/CristianHenzel/ClipIt/pull/90.patch
- )
+ fix_version.patch
+ https://patch-diff.githubusercontent.com/raw/CristianHenzel/ClipIt/pull/90.patch)
md5sums=('d49b9171c0b81269deafab9d6ecc7610'
+ '804f2a5bf60b5644087d2f8b7c227a0e'
'46e896a385ff9c8fa65c08d5d9d2e5c6')
prepare() {
cd $_pkgname-$pkgver
+ patch -p1 -i $srcdir/fix_version.patch
patch -p1 -i $srcdir/90.patch
}
diff --git a/fix_version.patch b/fix_version.patch
new file mode 100644
index 000000000000..fb9a6f495975
--- /dev/null
+++ b/fix_version.patch
@@ -0,0 +1,12 @@
+diff -rupN a/configure.ac b/configure.ac
+--- a/configure.ac 2018-06-28 20:16:38.000000000 +0200
++++ b/configure.ac 2018-08-09 14:52:24.250156973 +0200
+@@ -2,7 +2,7 @@
+ # Autoconf/automake.
+ # -------------------------------------------------------------------------------
+ AC_PREREQ([2.5])
+-AC_INIT([clipit], [1.4.3], [oss@rspwn.com])
++AC_INIT([clipit], [1.4.4], [oss@rspwn.com])
+ AM_INIT_AUTOMAKE
+
+ AC_CONFIG_MACRO_DIR([m4])