summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsvenschneider2014-08-02 23:03:26 +0200
committersvenschneider2014-08-02 23:03:26 +0200
commit3a3f0de88b8d7ee3803ad474b859201fa14f94b6 (patch)
tree7d2ed18be50b5f3dd11565227bded39cb0d3c286
parent47f9d0fbb556c95e993c23fc0dc7584c8694d522 (diff)
downloadaur-3a3f0de88b8d7ee3803ad474b859201fa14f94b6.tar.gz
[clips] updated to 6.30
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD44
-rw-r--r--clips.install14
3 files changed, 26 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 145b90f3ed7d..07d3ed9b95ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
pkgbase = clips
- pkgdesc = A Tool for Building Expert Systems
- pkgver = 6.24
- pkgrel = 3
+ pkgdesc = A forward-chaining rule-based programming language written in C that also provides procedural and object-oriented programming facilities.
+ pkgver = 6.30
+ pkgrel = 1
url = http://clipsrules.sourceforge.net/
- install = clips.install
arch = i686
arch = x86_64
- license = custom
+ license = GPL
depends = termcap
depends = libxaw
depends = xbitmaps
- source = http://downloads.sourceforge.net/clipsrules/clips_core_source_624.tar.Z
- source = http://downloads.sourceforge.net/clipsrules/x_windows_ide_source_624.tar.Z
- source = http://downloads.sourceforge.net/clipsrules/make_and_help_files_624.zip
- sha256sums = 80852a0df97597f710e90ca8bf5ecdc250c2034bf9dd3044bbedee111ad2e4ab
- sha256sums = 66429eb818559323f5e90bd7b3c1e4f88af409a30a3433111a1d85bc7c789d09
- sha256sums = 302712bbc2634cc437e6a7617d41ba54933ad6ffe5e01f0f869e9d7bc2cae9b8
+ source = http://downloads.sourceforge.net/project/clipsmm/clips/6.30.0.20090722svn/clips-6.30.0.20090722svn.tar.gz
+ md5sums = ff2e140deb47e3c0141f21fb238e2e61
+ sha256sums = 9114c371eb4e5a6bb32d746acb8d22591cba7502af2536a994e58a6349b30b2e
+ sha384sums = fe868fce6b8809d69eda21035aaf415b8ed04e460aab20e42bebaac55e2787634e843e94aa5b52eaa02f89b96601a654
+ sha512sums = df614f9a9611db31cb056160285af9bda88294b75ed378a71bdc395436cb511ddd9460d3aaaf0a54338c0e7c2c025ef53e3aa93701f1980d90010b61891f32d7
pkgname = clips
diff --git a/PKGBUILD b/PKGBUILD
index c5ac70c81134..8aac5309b0f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,32 @@
-# Maintainer: Thomas td123 Dziedzic <gostrc@gmail.com>
+# Maintainer: Sven Schneider <archlinux.sandmann@googlemail.com>
+# Contributor: Thomas td123 Dziedzic <gostrc@gmail.com>
# Contributor: Ivan c00kiemon5ter Kanakarakis <ivan.kanak@gmail.com>
# Contributor: jht <stefano@inventati.org>
pkgname=clips
-pkgver=6.24
-pkgrel=3
-pkgdesc='A Tool for Building Expert Systems'
+pkgver=6.30
+_pkgver=6.30.0.20090722svn
+pkgrel=1
+pkgdesc="A forward-chaining rule-based programming language written in C that also provides procedural and object-oriented programming facilities."
arch=('i686' 'x86_64')
url="http://clipsrules.sourceforge.net/"
-license=('custom')
+license=('GPL')
depends=('termcap' 'libxaw' 'xbitmaps')
-install='clips.install'
-source=('http://downloads.sourceforge.net/clipsrules/clips_core_source_624.tar.Z'
- 'http://downloads.sourceforge.net/clipsrules/x_windows_ide_source_624.tar.Z'
- 'http://downloads.sourceforge.net/clipsrules/make_and_help_files_624.zip')
-sha256sums=('80852a0df97597f710e90ca8bf5ecdc250c2034bf9dd3044bbedee111ad2e4ab'
- '66429eb818559323f5e90bd7b3c1e4f88af409a30a3433111a1d85bc7c789d09'
- '302712bbc2634cc437e6a7617d41ba54933ad6ffe5e01f0f869e9d7bc2cae9b8')
+source=(http://downloads.sourceforge.net/project/clipsmm/clips/${_pkgver}/${pkgname}-${_pkgver}.tar.gz)
+md5sums=('ff2e140deb47e3c0141f21fb238e2e61')
+sha256sums=('9114c371eb4e5a6bb32d746acb8d22591cba7502af2536a994e58a6349b30b2e')
+sha384sums=('fe868fce6b8809d69eda21035aaf415b8ed04e460aab20e42bebaac55e2787634e843e94aa5b52eaa02f89b96601a654')
+sha512sums=('df614f9a9611db31cb056160285af9bda88294b75ed378a71bdc395436cb511ddd9460d3aaaf0a54338c0e7c2c025ef53e3aa93701f1980d90010b61891f32d7')
build() {
- cd ${pkgname}src/${pkgname}src
+ cd "${srcdir}/${pkgname}-${_pkgver}"
- cp -a ../../x-prjct/color/* .
- cp -a ../../x-prjct/makefile/* .
- cp -a ../../x-prjct/xinterface/* .
-
- make -f makefile.x
-
- make -f ../../makefile.gcc
+ ./configure --prefix=/usr
+ make
}
package() {
- cd ${pkgname}src/${pkgname}src
+ cd "${srcdir}/${pkgname}-${_pkgver}"
- install -D -m755 xclips \
- ${pkgdir}/usr/bin/clips
- install -D -m755 clips \
- ${pkgdir}/usr/bin/clips-console
- install -D -m644 ../readme.txt \
- ${pkgdir}/usr/share/licenses/clips/LICENSE
+ make DESTDIR="${pkgdir}" install
}
diff --git a/clips.install b/clips.install
deleted file mode 100644
index 1e4c2b4bb3dd..000000000000
--- a/clips.install
+++ /dev/null
@@ -1,14 +0,0 @@
-
-# arg 1: the new package version
-post_install()
-{
- echo "Now you can launch X11-based version with: clips"
- echo "And console-based version with: clips-console"
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade()
-{
- post_install $1
-}