summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsvenschneider2014-08-02 23:02:07 +0200
committersvenschneider2014-08-02 23:02:07 +0200
commit47f9d0fbb556c95e993c23fc0dc7584c8694d522 (patch)
tree07355dd61c402b819df36a39a6ef97dfe39cd76c
downloadaur-47f9d0fbb556c95e993c23fc0dc7584c8694d522.tar.gz
[clips] add original version
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
-rw-r--r--clips.install14
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..145b90f3ed7d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = clips
+ pkgdesc = A Tool for Building Expert Systems
+ pkgver = 6.24
+ pkgrel = 3
+ url = http://clipsrules.sourceforge.net/
+ install = clips.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = termcap
+ depends = libxaw
+ depends = xbitmaps
+ source = http://downloads.sourceforge.net/clipsrules/clips_core_source_624.tar.Z
+ source = http://downloads.sourceforge.net/clipsrules/x_windows_ide_source_624.tar.Z
+ source = http://downloads.sourceforge.net/clipsrules/make_and_help_files_624.zip
+ sha256sums = 80852a0df97597f710e90ca8bf5ecdc250c2034bf9dd3044bbedee111ad2e4ab
+ sha256sums = 66429eb818559323f5e90bd7b3c1e4f88af409a30a3433111a1d85bc7c789d09
+ sha256sums = 302712bbc2634cc437e6a7617d41ba54933ad6ffe5e01f0f869e9d7bc2cae9b8
+
+pkgname = clips
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5ac70c81134
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Thomas td123 Dziedzic <gostrc@gmail.com>
+# Contributor: Ivan c00kiemon5ter Kanakarakis <ivan.kanak@gmail.com>
+# Contributor: jht <stefano@inventati.org>
+
+pkgname=clips
+pkgver=6.24
+pkgrel=3
+pkgdesc='A Tool for Building Expert Systems'
+arch=('i686' 'x86_64')
+url="http://clipsrules.sourceforge.net/"
+license=('custom')
+depends=('termcap' 'libxaw' 'xbitmaps')
+install='clips.install'
+source=('http://downloads.sourceforge.net/clipsrules/clips_core_source_624.tar.Z'
+ 'http://downloads.sourceforge.net/clipsrules/x_windows_ide_source_624.tar.Z'
+ 'http://downloads.sourceforge.net/clipsrules/make_and_help_files_624.zip')
+sha256sums=('80852a0df97597f710e90ca8bf5ecdc250c2034bf9dd3044bbedee111ad2e4ab'
+ '66429eb818559323f5e90bd7b3c1e4f88af409a30a3433111a1d85bc7c789d09'
+ '302712bbc2634cc437e6a7617d41ba54933ad6ffe5e01f0f869e9d7bc2cae9b8')
+
+build() {
+ cd ${pkgname}src/${pkgname}src
+
+ cp -a ../../x-prjct/color/* .
+ cp -a ../../x-prjct/makefile/* .
+ cp -a ../../x-prjct/xinterface/* .
+
+ make -f makefile.x
+
+ make -f ../../makefile.gcc
+}
+
+package() {
+ cd ${pkgname}src/${pkgname}src
+
+ install -D -m755 xclips \
+ ${pkgdir}/usr/bin/clips
+ install -D -m755 clips \
+ ${pkgdir}/usr/bin/clips-console
+ install -D -m644 ../readme.txt \
+ ${pkgdir}/usr/share/licenses/clips/LICENSE
+}
diff --git a/clips.install b/clips.install
new file mode 100644
index 000000000000..1e4c2b4bb3dd
--- /dev/null
+++ b/clips.install
@@ -0,0 +1,14 @@
+
+# arg 1: the new package version
+post_install()
+{
+ echo "Now you can launch X11-based version with: clips"
+ echo "And console-based version with: clips-console"
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade()
+{
+ post_install $1
+}