summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander 'chron' Kempen2017-07-04 15:32:25 +0200
committerAlexander 'chron' Kempen2017-07-04 15:32:25 +0200
commit755b688ab319e0b4db6c8030c1bd09389f2ae335 (patch)
tree7221c3e9e9a37cb3ae1becee6e2148176bae9b4e
downloadaur-755b688ab319e0b4db6c8030c1bd09389f2ae335.tar.gz
Initial commit, Version 1.0.3
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd9c7ca8d0a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = clipster
+ pkgdesc = Python clipboard manager
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/mrichar1/clipster
+ arch = any
+ license = AGPL
+ makedepends = git
+ depends = python
+ depends = python-gobject
+ depends = libwnck3
+ provides = clipster
+ conflicts = clipster-git
+ source = clipster-1.0.3::git+https://github.com/mrichar1/clipster.git#tag=1.0.3
+ sha256sums = SKIP
+
+pkgname = clipster
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7fcad9e347f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Alexander Kempen <alexander dot kempen at posteo dot de>
+# Contributor: Samuel Walladge <samuel at swalladge dot id dot au>
+
+pkgname=clipster
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Python clipboard manager"
+arch=("any")
+url="https://github.com/mrichar1/clipster"
+license=("AGPL")
+depends=("python" "python-gobject" "libwnck3")
+makedepends=("git")
+source=("$pkgname-$pkgver::git+https://github.com/mrichar1/clipster.git#tag=1.0.3")
+sha256sums=("SKIP")
+provides=("clipster")
+conflicts=("clipster-git")
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1
+}