summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-04-01 13:12:59 -0600
committerMark Wagie2021-04-01 13:12:59 -0600
commit07cde557cdb0cce921ebf26135534e1a6998a501 (patch)
tree4db40abc65cb8fd2c03327a0159b493f8ac080c1
parentca6e7107a222347e6d723a539368dfbd0aa3c76e (diff)
downloadaur-07cde557cdb0cce921ebf26135534e1a6998a501.tar.gz
use Electron 11
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--clipto2
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 198c8e21308b..8c4ab46ecc3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = clipto-bin
pkgdesc = Effortless, super fast and flexible notes taking app and clipboard manager.
pkgver = 4.7.3
- pkgrel = 1
+ pkgrel = 2
url = https://clipto.pro
arch = x86_64
license = custom
- depends = electron
+ depends = electron11
optdepends = libnotify: for desktop notifications
optdepends = libappindicator-gtk3: for tray icon
provides = clipto
@@ -15,7 +15,7 @@ pkgbase = clipto-bin
source = https://github.com/clipto-pro/Desktop/releases/download/v4.7.3/clipto-4.7.3.AppImage
source = clipto
sha256sums = 41e5efe788a3ea0c664a410ed33cc445035f0c3bf7855df80d2f0186d972b258
- sha256sums = 9a741f1a1760de706698cb1576e3bb08846876c359aedd5d8854e69d913f0635
+ sha256sums = 3adf08e3c2b3a6a41c60b66e53d610d4b6ca616e560fae1843c07c530e8c03fd
pkgname = clipto-bin
diff --git a/PKGBUILD b/PKGBUILD
index c1660ea7ee4f..e6de659596e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=clipto-bin
pkgver=4.7.3
-pkgrel=1
+pkgrel=2
pkgdesc="Effortless, super fast and flexible notes taking app and clipboard manager."
arch=('x86_64')
url="https://clipto.pro"
license=('custom')
-depends=('electron')
+depends=('electron11')
optdepends=('libnotify: for desktop notifications'
'libappindicator-gtk3: for tray icon')
provides=("${pkgname%-bin}")
@@ -15,7 +15,7 @@ replaces=("${pkgname%-bin}.pro")
source=("https://github.com/clipto-pro/Desktop/releases/download/v$pkgver/${pkgname%-bin}-$pkgver.AppImage"
"${pkgname%-bin}")
sha256sums=('41e5efe788a3ea0c664a410ed33cc445035f0c3bf7855df80d2f0186d972b258'
- '9a741f1a1760de706698cb1576e3bb08846876c359aedd5d8854e69d913f0635')
+ '3adf08e3c2b3a6a41c60b66e53d610d4b6ca616e560fae1843c07c530e8c03fd')
prepare() {
chmod +x "${pkgname%-bin}-$pkgver.AppImage"
diff --git a/clipto b/clipto
index 51e3b9500f2c..dbdcb5453c2a 100644
--- a/clipto
+++ b/clipto
@@ -1,3 +1,3 @@
#!/bin/bash
-exec electron /usr/lib/clipto/resources/app.asar "$@"
+exec electron11 /usr/lib/clipto/resources/app.asar "$@"