summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-03-11 17:37:06 -0600
committerMark Wagie2020-03-11 17:37:06 -0600
commit967c4b614a0895b990c935344ecc9bbda78d6051 (patch)
treec531d393edd8ff024950a34f0100a35d585ea2a9
downloadaur-967c4b614a0895b990c935344ecc9bbda78d6051.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
-rw-r--r--clipto3
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ccaee19308fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = clipto-bin
+ pkgdesc = Effortless, super fast and flexible notes taking app and clipboard manager.
+ pkgver = 2.4.6
+ pkgrel = 1
+ url = https://clipto.pro
+ arch = x86_64
+ license = custom
+ depends = nss
+ depends = libxss
+ depends = libxtst
+ depends = libappindicator-gtk3
+ depends = libnotify
+ provides = clipto
+ conflicts = clipto
+ conflicts = clipto.pro
+ replaces = clipto.pro
+ source = https://github.com/clipto-pro/Desktop/releases/download/v2.4.6/clipto-2.4.6.AppImage
+ source = clipto
+ sha256sums = 9d0dea1830dff1fcb4a25689c49cf3e309c8d408da21087d28810b734664ff12
+ sha256sums = a68ea565595fca737ff54b7a29e04f5059e5897955ab15c09ca9f36eb70fcfdb
+
+pkgname = clipto-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a76d17cf6660
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=clipto-bin
+pkgver=2.4.6
+pkgrel=1
+pkgdesc="Effortless, super fast and flexible notes taking app and clipboard manager."
+arch=('x86_64')
+url="https://clipto.pro"
+license=('custom')
+depends=('nss' 'libxss' 'libxtst' 'libappindicator-gtk3' 'libnotify')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}" "${pkgname%-bin}.pro")
+replaces=("${pkgname%-bin}.pro")
+source=("https://github.com/clipto-pro/Desktop/releases/download/v$pkgver/${pkgname%-bin}-$pkgver.AppImage"
+ "${pkgname%-bin}")
+sha256sums=('9d0dea1830dff1fcb4a25689c49cf3e309c8d408da21087d28810b734664ff12'
+ 'a68ea565595fca737ff54b7a29e04f5059e5897955ab15c09ca9f36eb70fcfdb')
+
+prepare() {
+ chmod +x "${pkgname%-bin}-$pkgver.AppImage"
+ ./"${pkgname%-bin}-$pkgver.AppImage" --appimage-extract
+
+ sed -i 's|Exec=AppRun|Exec=/opt/clipto/clipto|g' "squashfs-root/${pkgname%-bin}.desktop"
+}
+
+package() {
+ find squashfs-root/{locales,resources,usr/share/icons}/ -type d -exec chmod 755 {} +
+
+ install -d "$pkgdir/opt/${pkgname%-bin}"
+ cp -r squashfs-root/* "$pkgdir/opt/${pkgname%-bin}"
+ rm -rf "$pkgdir/opt/${pkgname%-bin}/usr"
+ rm "$pkgdir/opt/${pkgname%-bin}"/{"${pkgname%-bin}".desktop,AppRun}
+
+ install -Dm755 "${pkgname%-bin}" -t "$pkgdir/usr/bin"
+
+ install -Dm644 "squashfs-root/${pkgname%-bin}.desktop" -t "$pkgdir/usr/share/applications"
+
+ install -d "$pkgdir/usr/share/icons"
+ cp -r squashfs-root/usr/share/icons/hicolor "$pkgdir/usr/share/icons"
+}
diff --git a/clipto b/clipto
new file mode 100644
index 000000000000..0deff7b73e34
--- /dev/null
+++ b/clipto
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+/opt/clipto/clipto