summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-04-30 14:26:07 -0600
committerMark Wagie2024-04-30 14:26:07 -0600
commitadf6b46285b168c52a00946f9e9de333eeb39df5 (patch)
tree50412d3e6f8fe292de4eb2a1efe3773b8b3c1141
parent53454fc3db05cdcfe84ce74e584fd87f3aad1de9 (diff)
downloadaur-adf6b46285b168c52a00946f9e9de333eeb39df5.tar.gz
use desktop-file-edit instead of sed
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac7b6ca63ec7..6ae0131668e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,10 +19,12 @@ prepare() {
./"${pkgname%-bin}-$pkgver.AppImage" --appimage-extract
# Correct path for .desktop file
- sed -i 's|Exec=AppRun|Exec=clipto|g' "squashfs-root/${pkgname%-bin}.desktop"
+ desktop-file-edit --set-key=Exec --set-value="${pkgname%-bin}" \
+ "squashfs-root/${pkgname%-bin}.desktop"
# Remove X-AppImage-Version
- sed -i '/AppImage/d' "squashfs-root/${pkgname%-bin}.desktop"
+ desktop-file-edit --remove-category=X-AppImage-Version \
+ "squashfs-root/${pkgname%-bin}.desktop"
# Remove invalid symlink
rm squashfs-root/clipto.png