summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-06-22 14:47:40 -0600
committerMark Wagie2023-06-22 14:47:40 -0600
commitc95c549a312e380a91842fe1f3124b7355250923 (patch)
treef90a49dfbd636e8dc019e21dd488c2a15e1a27e9
parent59e8407d62285bbba7ad6944fb972daa590d34fd (diff)
downloadaur-c95c549a312e380a91842fe1f3124b7355250923.tar.gz
Electron 21 is deprecated, use included Electron
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD35
-rw-r--r--clipto3
3 files changed, 28 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14e3eeb89b17..63fa41eba38d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = clipto-bin
pkgdesc = Effortless, super fast and flexible notes taking app and clipboard manager.
pkgver = 7.2.17
- pkgrel = 11
+ pkgrel = 12
url = https://clipto.pro
arch = x86_64
license = custom
- depends = electron21
+ depends = alsa-lib
+ depends = gtk3
+ depends = nss
+ optdepends = libnotify: for desktop notifications
+ optdepends = libappindicator-gtk3: for tray icon
provides = clipto
conflicts = clipto
conflicts = clipto.pro
replaces = clipto.pro
source = https://github.com/clipto-pro/Desktop/releases/download/v7.2.17/clipto-7.2.17.AppImage
- source = clipto
sha256sums = ed0fc3b0e84efc986fdb41a1a38a1483c61d3c128eaa5014e97dc14c3b376028
- sha256sums = 7c299ef6dfa822911c2facd564b1459a7564be07a6e89875f0fca1d357374ec4
pkgname = clipto-bin
diff --git a/PKGBUILD b/PKGBUILD
index 220b03f3506b..7368ce1695b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,48 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=clipto-bin
pkgver=7.2.17
-pkgrel=11
-_electronversion=21
+pkgrel=12
pkgdesc="Effortless, super fast and flexible notes taking app and clipboard manager."
arch=('x86_64')
url="https://clipto.pro"
license=('custom')
-depends=("electron${_electronversion}")
+depends=('alsa-lib' 'gtk3' 'nss')
+optdepends=('libnotify: for desktop notifications'
+ 'libappindicator-gtk3: for tray icon')
provides=("${pkgname%-bin}")
conflicts=("${pkgname%-bin}" "${pkgname%-bin}.pro")
replaces=("${pkgname%-bin}.pro")
-source=("https://github.com/clipto-pro/Desktop/releases/download/v$pkgver/${pkgname%-bin}-$pkgver.AppImage"
- "${pkgname%-bin}")
-sha256sums=('ed0fc3b0e84efc986fdb41a1a38a1483c61d3c128eaa5014e97dc14c3b376028'
- '7c299ef6dfa822911c2facd564b1459a7564be07a6e89875f0fca1d357374ec4')
+source=("https://github.com/clipto-pro/Desktop/releases/download/v$pkgver/${pkgname%-bin}-$pkgver.AppImage")
+sha256sums=('ed0fc3b0e84efc986fdb41a1a38a1483c61d3c128eaa5014e97dc14c3b376028')
prepare() {
chmod +x "${pkgname%-bin}-$pkgver.AppImage"
./"${pkgname%-bin}-$pkgver.AppImage" --appimage-extract
+ # Correct path for .desktop file
sed -i 's|Exec=AppRun|Exec=clipto|g' "squashfs-root/${pkgname%-bin}.desktop"
+
+ # Remove X-AppImage-Version
+ sed -i '/AppImage/d' "squashfs-root/${pkgname%-bin}.desktop"
+
+ # Remove invalid symlink
+ rm squashfs-root/clipto.png
}
package() {
cd "$srcdir/squashfs-root"
find {locales,resources,usr/share/icons}/ -type d -exec chmod 755 {} +
- install -d "$pkgdir/usr/lib/${pkgname%-bin}"
- cp -r resources "$pkgdir/usr/lib/${pkgname%-bin}"
+ install -d "$pkgdir/opt/${pkgname%-bin}"
+ cp -r * "$pkgdir/opt/${pkgname%-bin}/"
- install -Dm755 "$srcdir/${pkgname%-bin}" -t "$pkgdir/usr/bin"
+ install -d "$pkgdir/usr/bin"
+ ln -s "/opt/${pkgname%-bin}/${pkgname%-bin}" -t "$pkgdir/usr/bin/"
- install -Dm644 "${pkgname%-bin}.desktop" -t "$pkgdir/usr/share/applications"
+ install -Dm644 "${pkgname%-bin}.desktop" -t "$pkgdir/usr/share/applications/"
install -d "$pkgdir/usr/share/icons"
- cp -r usr/share/icons/hicolor "$pkgdir/usr/share/icons"
+ cp -r usr/share/icons/hicolor "$pkgdir/usr/share/icons/"
+
+ rm -rf "$pkgdir/opt/${pkgname%-bin}/usr/"
}
diff --git a/clipto b/clipto
deleted file mode 100644
index 2752a00515af..000000000000
--- a/clipto
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/bash
-
-exec electron21 /usr/lib/clipto/resources/app.asar "$@"